I just installed phpmyadmin and i am trying to login in /phpmyadminpath/setup.

I am greeted by an invite similar to an apache protected folder (log/password displayed in a browser pop-up, not an html popup) asking for login pass.

I cannot login using system password(root) or mysql passsword(also root)

I already have rails app using this mysql, and i checked the mysql password in the config files.

The root folder of phpmyadmin is a totally blank page.

I cannot run any mysql command in my console because of the following error :

ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: NO)

What is wrong with phpmyadmin and mysql?


While uninstalling phpmyadmin with apt-get i encountered the following error :

ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: YES)

Is it a wrong root password ? How can root not be allowed to do something?


So i tried a few thing :

Set ALL phpmyadmin folders to belong to www-data use. Set php.ini to display all errors and setting errors to alway display at the start of index.php of my phpmyadmin folder.

I tried sudo dpkg-reconfigure phpmyadmin but it fails to connect to mysql, in TCP/IP and in socket (i have running rails apps using mysql, i can login in console using a PW and see my DBs).

I have restarted mysql to change password.

I added a phpinfo test page in phpmyadmin, i can see the whole page with php infos.

phpmyadmin still display a blank page with it's favicon.

apache2 errors logs are empty

  • You said "I cannot run any mysql command in my console" but also "I can login console using a PW" -- which is it; can you or can't you log in from the console? It really looks like you or someone changed the password associated with your MySQL accounts, which threw apt in to confusion because the password it uses for maintenance doesn't match anymore (maintenance including removing the phpMyAdmin database and account, which is why you got the error when trying to remove it). – ibennetch Jul 19 '14 at 13:59
ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: NO)

There's your problem - phpMyAdmin is not sending a password.
Configure phpMyAdmin to properly authenticate to your MySQL server.

Information on how to do this can be found in the phpMyAdmin documentation.

  • This happen outside of apache2/phpmyadmin – Sylario Sep 3 '12 at 14:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.