I try to mount a .iso and get the following eror on windows Server 2012

"sorry, there was a problem mounting the file."

Anyone ?

It seems like it works fine if I mount it not through mapping drive.

  • Did you verify that the iso's md5sum matched what it was supposed to be?
    – EEAA
    Sep 6, 2012 at 4:24
  • I have mounted it successfully without using mapping drive. I just got curious why I can mount it over unc-path but can't mount it through mapping drive
    – maxisam
    Sep 6, 2012 at 4:30

4 Answers 4


The error message is not very clear so here are some tips on debugging the issue. Open up a Powershell command prompt and type the following (from here) :

function Resolve-Error ($ErrorRecord=$Error[0])
   $ErrorRecord | Format-List * -Force
   $ErrorRecord.InvocationInfo |Format-List *
   $Exception = $ErrorRecord.Exception
   for ($i = 0; $Exception; $i++, ($Exception = $Exception.InnerException))
   {   "$i" * 80
       $Exception |Format-List * -Force

Next type the following command to mount your image. Change the "ImagePath" parameter with the path to your ISO:

Mount-DiskImage -Verbose -StorageType "ISO"  -ImagePath "C:\Downloads\Core-current.iso"

The "-verbose" flag should give you some info but type the following command immediately after executing the above might give you more debug info:


Paste the error message back here if it gets you nowhere and see if someone can help :)

  • Interesting. Mount-DiskImage actually succeeded in mounting the image. But I still get the same error message double click the ISO in Explorer to mount it - and then the disk gets mounted. Feb 5, 2013 at 1:44
  • Hmm.sounds explorer related...saw an answer here social.technet.microsoft.com/Forums/en/winserver8gen/thread/… ...'Right click on the image and choose open with "Choose default program.." Then select "Windows Explorer". It appears that the default application associated with the image causes the mount option to fail.'
    – Ameer Deen
    Feb 5, 2013 at 2:07
  • Re-associating the file extension with Explorer did solve the issue for me. Thanks! Feb 5, 2013 at 17:26

If you downloaded the iso from Microsoft using their Akamai NetSession client then this is actually a bug in the downloader.

When you right click and try to mount, you will get this error:

enter image description here

The problem is that their required download manager is setting the download file to be a sparse file as can be seen by the "P" attribute in the screenshot below.

enter image description here

The easiest way to fix this is to copy the file so that the sparse attribute is gone. Normally if you copy using Windows Explorer the sparse attribute will be removed.

Credit for this info goes to : Bug of the Day: Couldn't Mount File in Windows 8.1


This is caused, because the file is marked as sparse (For more information here: https://msdn.microsoft.com/en-us/library/windows/desktop/aa365564%28v=vs.85%29.aspx ) I had the same problem and I found two solutions.

Solution 1:
If the file or image (as mountable file) is less than 10 GB in size, just copy the file.

Solution 2:
If the file or image (as mountable file) is greater than 10 GB in size or/and you don't have space on your HDD. Try this:

1. Check if the file is Read-Only from the Properties panel. If it is, remove the check in the checkbox and Apply;
2. Check if the file is Blocked from the Properties panel right below the permissions for read, hide. If it is click the button 'Unblock' to unblock it;
3. Run PowerShell or Command Prompt as administrator;
4. Navigate to the directory in which the file is located;
5. Execute the following command:
fsutil sparse setflag "<file_name>.iso" 0
6. Mount the file

NOTE: Use quotes in the file name of the file if the file name contains white spaces.


I had a similar problem with a different solution, the ISO was housed on a network share and the drive was not mounted under the local server administrator credentials. I mounted the same drive letter and path as the explorer session I was using under an elevated command prompt and the explorer mount worked..

  • Solved it for me. I was running in a VM. Sep 7, 2016 at 10:17

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .