6

Trying to upgrade Windows Server from 2008 R2 to 2012. On compatibility check throwing an error

Active Directory on this domain controller does not contain Windows Server 2012
ADPREP /FORESTPREP updates. See http://go.microsoft.com/fwlink/?LinkId=113955.  

As per the suggested above link did what required; but still throwing same error.

Any helps?

11
  • Is there another DC?
    – gravyface
    Sep 6, 2012 at 11:13
  • 3
    @Nev - just a comment, why so quick to leap into this version, it's VERY new.
    – Chopper3
    Sep 6, 2012 at 11:42
  • @Chopper3 especially on a DC shudder
    – gravyface
    Sep 6, 2012 at 11:55
  • Did you do both a domain prep and a forest prep? Have you raised the functional level of the forest and the domain to 2008? Sep 6, 2012 at 13:23
  • @ChrisMcKeown Uh, you can't raise a functional level above the oldest DC on the forest/domain. So that's not going to help him when he can't get all this DCs up to 2012. Sep 6, 2012 at 15:47

4 Answers 4

7

@Nev, I had the same error. The Microsoft link suggest to use the Windows 2008R2 disc, however the updates are on the 2012 disc. For me the solution was to perform the Microsoft solution with the Windows 2012 disc and reboot. The same goes for the ADPREP /DOMAINPREP updates.

1
  • +1 for this answer - I did not need to reboot though. Sep 16, 2012 at 12:03
5

Just cd to support\adprep on the Windows 2012 media and run:

adprep /forestprep
adprep /domainprep
1
  • I can confirm this also works for the Windows Server 2016 to Windows Server 2019 in-place upgrade. I couldn't cd into the ISO, so I had to unpack it to disk first, then cd into it and it worked.
    – JJJ
    Apr 30, 2019 at 16:55
1

You run adprep /forestprep from from 2012 media on the DC holding the Schema Master role in your forest. Then, you run adprep /domainprep and adprep /gpprep from the 2012 media on the DC holding the Infrastructure Master role in the domain that you're putting the 2012 DC in.

2
  • is adprep /gpprep needed?
    – dataCore
    Jan 16, 2015 at 12:45
  • @dataCore it wasn't for me
    – Matthieu
    Apr 10, 2020 at 15:10
0

I just want to add that if the error still appear after doing the adprep /forestprep adprep /domainprep It could be a problem in replication between the DCs (which was in my case) so also check the replication

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.