The last two times I ran freebsd-update install the machine (re)booted from the GENERIC kernel instead of my custom kernel.

As suggested by Freebsd Update (section 25.2.2) I have a GENERIC kernel in /boot/GENERIC:

Note: It is a good idea to always keep a copy of the GENERIC kernel in /boot/GENERIC. It will be helpful in diagnosing a variety of problems, and in performing version upgrades using freebsd-update as described in Section 25.2.3.

Now this breaks my remote access to the machine because networking will not properly do its job with GENERIC (the main reason being the missing dummynet support, I believe).

Anyways: I am not sure if a) this behaviour is by design (e.g. it is not clear if a custom kernel will boot after the upgrade so GENERIC is booted if available) and b) if I could circumvent this by always rebuilding my custom kernel after running freebsd-update install and before rebooting.

b) is supported by the fact that the machine successfully boots from my custom kernel after I physically access it and recompile my kernel.

Or did I get something about freebsd-update completely wrong?


Have you tried to put this to your /boot/loader.conf?


Should work with GENERIC kernel, too.

  • No, I have not tried this. But I will :) And it would still be great to know if this behaviour is by design anyway. – scherand Sep 9 '12 at 12:32
  • Well with the generic kernel you are supposed to put more exotic things such as dummynet to /boot/loader.conf anyway, I think. – Janne Pikkarainen Sep 9 '12 at 12:33
  • OK. But dummynet is only on the sideline of my question. What really nags me is why the generic kernel is booted at all. I mean, I don't technically have to have it around, do I? – scherand Sep 9 '12 at 12:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.