I installed a VSFTP daemon on a CentOS server, using a RSA certificate for logging in using explicit TLS. Now, I cannot upload more than 82k.

With files under that limit, there is no problem. The FTP works like a charm. But as soon as a file reaches 82k with FileZilla (81,952 bytes to be exact), the transfer will stop, and the FTP client hangs until time out is reached.

FTP client console:

15:10:21    Command:    STOR jquery-1.7.2.min.js  
15:10:21    Response:   150 Ok to send data.  
15:11:21    Error:  Connection timed out  
15:11:21    Error:  File transfer failed after transferring 82 KB in 60 seconds  


FTP command:  Client "x.x.x.x", "STOR jquery-1.7.2.min.js"
FTP response: Client "x.x.x.x", "150 Ok to send data."
OK UPLOAD:    Client "x.x.x.x", "jquery-1.7.2.min.js", 81952 bytes, 1.32Kbyte/sec
FTP response: Client "x.x.x.x", "226 File receive OK." // NOT okay, file is bigger
// No mention of error here

I cannot find relevant info about this problem, apart from a possible problem with trans_chunk_size (not mentioned in default config), but I tried different sizes and it has no impact on the problem. trans_chunk_size=4096

Ofcourse, after every configuration change, I restarted the server:
/etc/init.d/vsftpd restart

What else can cause this?

It's not the latest version, but it's the latest update within the repositories that has been deemed fit for enterprise usage:

Package info:

$ yum info vsftpd  
Loaded plugins: fastestmirror  
Installed Packages  
Name       : vsftpd  
Arch       : x86_64  
Version    : 2.0.5  
Release    : 24.el5_8.1  
Size       : 286 k  
Repo       : installed  
Summary    : vsftpd - Very Secure Ftp Daemon  
URL        : http://vsftpd.beasts.org/  
License    : GPL  
Description: vsftpd is a Very Secure FTP daemon. It was written completely from scratch.  
  • Got pcaps showing whether the problem's at the network layer or not? – womble Nov 4 '15 at 4:57

It sounds like the problem is at the client side. Have you tried another client program: lftp, TLSWrap, ...?

  • Thanks. Before I set this up, I was running the same daemon without TLS and it worked fine. I would have to set up a different FTP server also with RSA/TLS. – Redsandro Sep 10 '12 at 16:24

I don't use FTP on my server anymore, too much hassle.

But if I remember correctly, the problem was indeed (partially) client-side and a workaround was to compile the latest version of FileZilla. Not the (forever outdated) version in the Ubuntu repositories.

This is what the guys at FileZilla pointed out themselves, but I cannot find the resource back at this moment.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.