I'm using Red Hat 5 client to authenticate to a Windows 2003 KDC (or trying to anyway), but when I run

kinit vwwebseal@VWXAUTHN.LOCAL

I get

kinit(v5): Cannot find KDC for requested realm while getting initial credentials

When I use nslookup, the Red Hat machine can successfully look up the KDC:

[root@vwwebseal ~]# nslookup vwkdc.vwxauthn.local

Name:   vwkdc.vwxauthn.local

This is my krb5.conf file:

default_realm = VWXAUTHN.LOCAL
default_keytab_name = FILE:/etc/krb5/krb5.keytab
default_tkt_enctypes = rc4-hmac
default_tgs_enctypes = rc4-hmac

kdc = vwkdc.vwxauthn.local:88
admin_server = vwkdc.vwxauthn.local:749
default_domain = vwxauthn.local

.vwxauthn.local = VWXAUTHN.LOCAL
vwkdc.vwxauthn.local = VWXAUTHN.LOCAL

kdc = FILE:/var/krb5/log/krb5kdc.log
admin_server = FILE:/var/krb5/log/kadmin.log
default = FILE:/var/krb5/log/krb5lib.log

  • When I use nslookup, the Red Hat machine can successfully look up the KDC (vwkdc.vwxauthn.local). --> Could you please show us the output? – quanta Sep 11 '12 at 4:22
  • Check /etc/hosts (or run getent hosts vwkdc.vwxauthn.local) if nsswitch.conf means kerberos uses the hosts file rather than DNS to look for the KDC. – ramruma Sep 11 '12 at 6:55

It's okay, I solved it. When I ran config.krb5 it created a file at /etc/krb5/krb5.conf, but a file already existed at /etc/krb5.conf. It was using that configuration instead of the one I created, so I removed /etc/krb5.conf.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.