0

When I run php -v

I get:

PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib64/php/modules/apc.so' - /usr/lib64/php/modules/apc.so: undefined symbol: php_pcre_exec in Unknown on line 0

This isn't my first rodeo. I've setup APC multiple times. This is a MediaTemple Dedicated Virtual 4.0 with Plesk 11. Plesk 11 is the only thing essentially different from the other servers I've set this up on.

I've verified that pcre-devel is installed. I've compiled APC from source as well as used pecl to install it. No difference.

I also tried downgrading to APC 3.0.19, with no love.

  • 1
    Why not just use the packages provided by the distribution (and you forgot to mention which you're using)? – Michael Hampton Sep 11 '12 at 13:23
  • It's CentSO 6. If there are any yum packages for this, I haven't seen them. – clifgriffin Sep 11 '12 at 13:39
  • php-pecl-apc has been in the repos for quite some time. – Michael Hampton Sep 11 '12 at 15:00
  • For whatever, reason, it's not in my repos. "No package php-pecl-apc available." (please let me know if I'm missing something obvious...not an expert on this stuff) – clifgriffin Sep 11 '12 at 15:04
  • I suspect Plesk. But you'd have to ask MT to be sure. – Michael Hampton Sep 11 '12 at 15:08
0

First install the pecl package from yum repo and then use the below command to install the apc.

pecl install apc

that's it.

  • Yes, I used that method. As I said above "I've compiled APC from source as well as used pecl to install it. No difference." – clifgriffin Sep 11 '12 at 15:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.