I am trying to run iisreset on a windows-xp. It's not a domain machine, just a local workgroup we use for testing.

The error I get is : IIS Admin Service is Disabled

What I tried:

  • uninstall and reinstall IIS, reboot.
  • change the log-on user for the IIS Admin service - to local administrator rather than system
  • To note that the service is off course Enabled, and set to Automatic. If I stop it, and start: iisreset - it immediatly starts, but than I get the error message anyway.
  • I had an issue with the machine clock - fixed.

  • The following A suggests a Group Policy - Are there group policy on NON-Domain computers? IIS Admin Service is disabled


I tried the suggested: How do I restore the IUSR account used by IIS 6

  • It did not help.


When I try to restart/stop/start the IIS Admin from services.msc - it works fine. The problem is from CMD trying to run: iisreset

EDIT: Logging using the Administrator account on the machine, gets the same behavior:

IISRESET command, successfully stopping, but fails on starting, with the error: IIS Admin Service is Disabled.

enter image description here

EDIT: System event error: enter image description here

I need that : http://localhost will work on the PC.

Where else should I check?

  • anything in the event log immediately after a failed start? – ramruma Sep 19 '12 at 10:53
  • @ramruma answer edited with system event data – Saariko Sep 19 '12 at 10:58
  • have you tried the registry key solution in my answer and, if so, did it work? – ramruma Sep 20 '12 at 7:43
  • It works, bounty can be awarded only in 1 hour – Saariko Sep 20 '12 at 7:55

The event id 7023 and error message The World Wide Web Publishing Service service terminated with the following error: The parameter is incorrect (shown in your screenshot) lead to http://support.microsoft.com/kb/327649 which suggests the port range needs to be increased, and gives details of how to do it by either deleting the registry key HKEY_LOCAL_MACHINE\Software\Microsoft\Rpc or changing values underneath it. But before you change anything, remember the usual reason for specifying these values is so you know which ports to allow through firewalls, so remember to make the corresponding network changes.

| improve this answer | |

Have you changed the password for the IUSR account? Even if you haven't, it's probably worth re-syncing it with IIS.

Details in this question here

| improve this answer | |
  • Tried it, did not help - added to question – Saariko Sep 12 '12 at 13:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.