I have implemented DAOS on a Lotus Domino Server (8.5.3 FP2) as follows:

Lotus Domino Server Document:

  • Store file attachments in DAOS: Enabled
  • Minimum size of object before Domino will store in DAOS: 64000 bytes
  • DAOS base path: E:\DAOS
  • Defer object deletion for: 30 days

Transaction logging is running, and the specific test database has the following advanced properties set:

  • Domino Attachment and Object Service (ticked)
  • Use LZ1 compression for atachments
  • Compress Database Design
  • Compress Data

I have restarted the server. When I run a compact -c, it compacts the database, but does not reduce the size. I have checked the DB in Windows Explorer (60Gb) and the size is the same pre and post. I have checked the directory (E:\DAOS) and it is 35Gb in size.

When I run the command 'Tell DAOSMgr Status tmp\test.nsf', I get the following response. From looking up on the net, I believe ticket count = 0 means that the db is not really DAOS'ed?

Admin Process: Searching Administration Requests database
DAOSMGR: Status tmptest.nsf started
DAOS database status:

Database: E:\Lotus\Domino\Data\tmp\test.nsf
Database state = Synchronized
Last resynchronized: 03/09/2012 02:49:13 PM
Ticket count: 0
DAOSMGR: Status tmp\test.nsf completed

I have run fixup on the database. When I have tried to run the DAOS estimator it has always crashed. This was a problem with larger databases on earlier versions of domino, but not anymore.

Can anyone tell me why the size has not reduced? Am I missing anything?


I think you have DAOS slightly mixed up. DAOS removes the attachments out of documents and stores them on the server, so if one emails is sent with a large attachment it is not stored in every database, just one file in DAOS.

Here are some links:

http://www-01.ibm.com/support/docview.wss?uid=swg21449358 this is to reduce the number of nlo files.

Also someone on IBM support ask the same question, I would recommend reading it here

  • Thanks - I have looked into it further and have worked out the problem, see below. Thanks for the links, there was some confusion there. I am not looking to reduce the size of the NLO files, but the size of the DB. Looks like there was a db problem which is now resolved. – atom Sep 13 '12 at 22:19

So - looks like the problem was with the database. I ran a fixup on the db which deleted a corrupt document - this was a test db so will now find out what the corrupt document was.

Now, when I run 'Tell DAOSMgr Status tmp\test.nsf', I get the following response:

DAOSMGR: Status tmp\test.nsf started
DAOS database status:
Database: E:\Lotus\Domino\Data\tmp\test.nsf
Database state = Synchronized
Last resynchronized: 13/09/2012 07:24:33 PM
Ticket count: 106165
DAOSMGR: Status tmp\test.nsf completed

Ticket count no longer 0.


There are some important points when you implement DAOS (in my eyes). Some are also mentioned here

1.) You should keep your Backup software in mind, not every supports DAOS. If the software didn´t support DAOS you still CAN restore the mailfile but must then restore each *.nlo file per hand to the DAOS folder. You can find more infos here: http://www-10.lotus.com/ldd/dominowiki.nsf/dx/daos-backup-and-restore

So the most company's enable DAOS on there primary server (from a cluster) and on there 2nd server which act as failover they run the backup (without DAOS enabled).

2.) I would enable DAOS also on the mail.box as mentioned here: http://www-10.lotus.com/ldd/dominowiki.nsf/dx/daos-best-practices#Mailbox

3.) Keep in mind that the NLO files are encrypted on default. This might be a problem for the restore on your side.

http://www-10.lotus.com/ldd/dominowiki.nsf/dx/daos-best-practices#Encryption http://www.lntoolbox.com/en/notesini-reference/bycategory/14-server_configuration/2245-daosencryptnlo.html

4.) You should exclude the NLO via antivirus: http://www-10.lotus.com/ldd/dominowiki.nsf/dx/daos-best-practices#Antivirus

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.