Already asked this question on stackoverflow, but was told it should be here.


I just installed a Windows 2008 Standard R2 server with RDS and 10 licenses. Whenever I attempt to connect to the server via RDP from a Windows 2003 server, I get the following error.

enter image description here

I am however able to connect from a Windows 7 desktop and using a Linux RDP client. Anyone know why I'm getting this error and how to resolve the problem? Thank you in advance.

I have tried various settings in gpedit.msc, but I don't think the problem is coming from there since I am able to connect with those other RDP clients mentionned above.

Any help resolving this issue is greatly appreciated.

Update 3:04pm

Here are the RDP-Tcp properties from the Remote Desktop Session Host Server

enter image description here

As you can see, the Allow connections only from computers running Remote Desktop with Network Level Authentication checkbox was already unchecked.

Update: 4:42pm

From the W2K3 server I am trying to connect from, on the security tab, if I select Attempt authentification, I get this error:

enter image description here

  • Anything in the event log?
    – Zoredache
    Sep 13, 2012 at 16:09
  • Nothing of any use. I thought maybe it was the RDP client v6 on W2K3 and v7 on W2K8, but there is another RDS on W2K8 that accepts connectins from RDP v6.0 Sep 13, 2012 at 16:25

3 Answers 3


Theres a Microsoft KB for WinXP that may be relevant. Wouldn't hurt to check and see what's under HKLM\Software\Microsoft\MSLicensing

  • I agree. @Craig Efrein, check your licenses and you licensing mode (per-device or per-user) and make sure they match. Server 2008 R2 has nice licensing diagnostics that should tell you why the licensing isn't working correctly.
    – KJ-SRS
    Sep 13, 2012 at 19:17
  • It still doesn't make sense that I can connect with a Linux Client and the RDP v7 client but not the RDP v6 client. I will read through the article suggested by Charles and check out the licenses. Sep 14, 2012 at 5:07

I believe it's because your Windows Server 2008 is configured to only allow RDP sessions that supports "Network Level Authentication". http://technet.microsoft.com/en-us/library/cc732713.aspx

Activating NLA on Windows Server 2003 RDP Client

  • Thank you for your answer, I updated my question with a GUI referenced by your second link. Sep 13, 2012 at 13:08

Finally just upgraded the RDP client on the servers that needed to connect to this new machine. The above suggestions unfortunately did not help in this situation.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .