2

We're already configuring Internet Explorer proxy settings through group policy and it works great. Sadly, I've recently run into multiple issues where those settings are ignored by certain services.

I realized that these service have one thing in common. They use WinHTTP, which has its own proxy settings. Now I'm asking myself how to apply those across the whole domain.

I realize that I could create a logon script and simply run netsh winhttp import proxy source=ie, but, from experience I know that these settings require a reboot to take effect. So this wouldn't help me at all in a logon script.

So, how can I do it?

1

I know this is very old, but found this while searching for a solution to this very topic.

The settings are stored in a REG_BINARY in the registry at HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings\Connections in the Entry WinHttpSettings

This can be applied as a group policy object.

Don't yet know how portable (win7 win8 win10) this is though.

Found here (German) http://matthiaswolf.blogspot.de/2013_09_01_archive.html

0

Winhttp proxy setting need to be set using both the standard and the win64 path commands to be effective.

C:\Windows\system32\netsh

C:\Windows\SysWOW64\netsh

Invoking you commands from both start points is the first step so that you make sure that you are covered for all applications that use that entry point.

You can import the IE settings, however I usually like to specifically and programatically run this setting update. To be clear, I set the proxy, port , and bypass list entries explicitly via a remote script that hits all machines. A reboot is not technically needed, but a restart of the services that are hitting the proxy is needed. In my usage that would be IIS, so an IISRESET usually does the trick. Once these are set they are permanent.

-1

proxycfg -u

command above take current user settings and apply it.

  • 1
    From what I can tell that would do the equivalent of netsh winhttp import proxy source=ie in Windows Vista. So that doesn't really help me. – Der Hochstapler Oct 6 '12 at 19:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.