How can one set the executable bit on files using umask? According to documentation, a umask of 000 should work, but in practice this only works on directories.

Also open to other methods of automatically setting +rwx on a particular user's created files if you have any.

  • 1
    Why would you want to do this? There is a reason why things are not executable by default. It sounds like a potential security issue to me. – Zoredache Sep 13 '12 at 23:32

There is no general automatic way to have The file mode set to rwx. The umask setting does not set the bits it stops them from being set. It is up to the application that is creating the file to set the file mode appropriately which is then modified by umask.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.