I am trying to use the feature "Create a Report in Microsoft Excel" for Visual Studio TFS 2010.

I am being prompted for a username and password in Excel for any given Team Project when right clicking the item "Active Tasks", selecting "Create a Report in Microsoft Excel," found in the following path within the Team Explorer pane, from Visual Studio 2010:

'Collection Name' | 'Project Name' | Work Items | Iteration 1 | Active Tasks

I am a Team Project Administrator and Collection Administrator. I checked The SharePoint site:

http :// 'serverName'/Reports/Pages/Folder.aspx

and have full sitewide and project permissions on this site.

I loaded SQL Server Management Studio on the machine running the instance of TFS (and also the SQL backend for TFS) and ensured that I had roles "serveradmin" and "sysadmin".

How do I run this report? Specifically, what permissions are required?


I know this question is old, but in case anyone else stumbles here looking for the solution, you should check permissions on the Analysis Services Cube. Excel accesses the Cube in order to create the reports, so you must have access there as well as on the Tfs_Warehouse Db (same permissions required -- "TfsWarehouseDataReader").

In SSMS, click on "Connect" in "Object Explorer" and choose "Analysis Services..."

Next expand "Databases" --> "Tfs_Analysis" --> "Roles"

Right click on "TfsWarehouseDataReader" --> "Properties"

Click on "Membership", and then add your AD account into the list.

Hope that helps someone!


That's not a permission denied message you're receiving, so it's not likely you'll rid yourself of it by adding more permissions. What happens when you fill out the username and password? I don't see this behavior, and I run reports with Excel all the time. I wonder if something gets cached after the first authentication?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.