I'm trying to explore the contents of a VHD form a backup of my Rackspace server. Any idea on how I might be able to mount it and explore it's contents?

I've tried using the Computer Management tool in windows 7 without any luck. It seems to mount the VHD fine but will not assign it a drive letter or let me initialize it.

  • After a bit more trial and error, the approach recommended by someone at Rackspace worked. Use the Computer Management tool to mount the disk, and then ext2read to find that drive and explore its contents. Think I had issues because I was trying a few different methods for mounting the VHD and they were conflicting. Sep 18, 2012 at 1:48

1 Answer 1


You should be able to attach VHD files in diskmgmt.msc. Click Action > Attach VHD and select the VHD file. The volume should be marked as Online after it's attached. Right-click on the volume and select Change Drive Letter and Paths... to assign a drive letter.

DO NOT initialize the VHD. Initializing it will destroy the partition table.

If attaching the VHD did not work for you: how exactly did it "not work"? Did you get an error? (which?) Do related errors/warnings show up in the eventlog?

You could also try to open the VHD with WinImage.

Edit: Accessing Linux filesystems from Windows requires additional tools. Plus, you need to know which filesystem is being used.

I have only used Explore2fs and Ext2 IFS myself, so I can't say how reliable the other tools/drivers are. I'd be a good idea to work on a copy of the VHD, so you have a backup when something goes wrong.

Another route you could try would be to install VirtualBox, set up a Linux VM, connect the VHD file to the VM as a secondary volume, and then try to mount the filesystem on the VHD from Linux. Files could be transferred to the host OS via a shared folder.

  • It shows up as 'Online' but has no drive letter and the option to change drive letter and paths is greyed out. One gotcha is that I just learned it's from a Linux machine. Rackspace claims that I can use ext2read to read it after mounting the VHD, but that doesn't seem to work either. Sep 18, 2012 at 1:21
  • See updated answer. Sep 18, 2012 at 9:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.