Okay. Very strange problem that I'm having here. I just recently updated to Apache 2.4.2 from 2.2.17, mostly to try to get name-based SSL VirtualHosts working (although they should have been working on 2.2.17). Server is Win2008 R2 (so x64 by definition) running with PHP 5.4.3 and MySQL 5.1.40 (outdated, I know).

When I launch the server, it initially works fine. Responds to all requests, VirtualHosts all in order. However, after an uncertain amount of time (appears to only take a few minutes for the most part, but sometimes takes hours), it stops responding to regular HTTP requests (on any VirtualHost). HTTPS continues to work. No errors in the log, and nothing in the access logs when I attempt to connect.

I'm having a hard time finding the source of this error given its intermittent nature. When removing all SSL-based VirtualHosts, it seemingly increased stability (still responding to HTTP requests twelve hours later). This could be mere coincidence, though.

Entirety of SSL VirtualHost is as follows, should there happen to be a problem with it.

<VirtualHost *:443>
   DocumentRoot "C:\Server\www\virtualhosts\mysite.net"
   ErrorLog logs/ssl.mysite.net-error_log
   CustomLog logs/ssl.mysite.net-access_log common env=!dontlog
   SSLEngine on
   SSLProtocol all -SSLv2
   SSLCertificateFile C:/Server/bin/apache/apache2.4.2/conf/ssl/server.crt
   SSLCertificateKeyFile C:/Server/bin/apache/apache2.4.2/conf/ssl/server.key
   SSLCertificateChainFile C:/Server/bin/apache/Apache2.4.2/conf/ssl/sub.class1.server.ca.pem
   SSLCACertificateFile C:/Server/bin/apache/Apache2.4.2/conf/ssl/ca.pem

Any ideas what I'm missing?

  • Perhaps you were searching in the wrong place, since it might have to do with networking. Did you update any other packages when you upgraded Apache? Perhaps something that has to do with networking? Remember: http and https use different ports... Do you have an update about the outcome of your searches?
    – bizna
    Apr 1, 2015 at 13:25
  • I am in the same boat: upgraded from 2.2 to 2.4 and it started freezing not responding to the requests every few weeks. Same machine and OS, different Apache and PHP. Virtually the same configs with only adjustment for the new versions. Having to restart the service and it works for a few more weeks. Very frustrating.
    – ajeh
    Jan 14, 2017 at 14:46

2 Answers 2


We have solved a very similar issue on our server. See Apache randomly stops serving HTTPS, but HTTP works just fine

This settings in httpd.conf file fixed the problem:

AcceptFilter http none
AcceptFilter https none

Turn Log debug, and look into error log.


If requests don't get served, there must be something, at least some segfault notify.

Also, you can use "ab" utility to regenerate error after serving particular kind of requests


As last resort, you can start httpd from command line, and force debug mode / foreground with some switch of apache2 binary. It's impossible that nothing goes to the log about it. What kind of application do you serve on it, is it fastcgi, or some .net bridge ?

More, what exactly do you mean by "stops responding to regular HTTP requests" ? Do you have an 503 error in browser, or just nothing appears / connection fails?

  • Set it to debug and will see what I get the next time the issue occurs. This could be anywhere from a few minutes to hours.
    – Apropos
    Sep 17, 2012 at 22:02
  • Didn't see the last question. Nothing appears and connection fails, yes.
    – Apropos
    Sep 17, 2012 at 22:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.