We've got three Apple AirPort extremes and want to setup them as a roaming wlan network on my company. My question is what's the correct setup for this?

All three AP:s is supposed to create the same wireless network "MyWlan" and we want roaming supoprt between them so that client can move from floor to floor without having to switch wlan or reconnect.

We don't want to use any kind of DHCP or NAT on the AirPorts, only bridge mode.

Do we connect the AirPorts to the lan/ethernet using the WAN port or one of the LAN ports? What's the correct settings in the config utility? Have one of the AirPorts create a network and setup the other two to extend the created network from AirPort 1 or have them all create the same network and set the same wlan password?


Apple's documentation explains three ways to do this, depending on your AirPort Extreme model and physical facility requirements.

You will need to configure the devices with AirPort Utility (and probably with a Mac), but you likely already have one.


Whatever you do there will be a slight break in connection. For a very basic set up you should configure the airports to be access points, allow them to get their own address via DHCP and plug them in to a port on each floor, then configure them all with the same SSID and password.

This will allow users to walk through all floors without having to reconnect BUT it will not , and cannot, support a fluid transition from one AP to the next, i.e if you want to use anything with live data such as VOIP etc it will break as you cross the boundary from one AP to the other.

The only product I know of that gets around this is Extricom, who are expensive, but have their own proprietary "blanket" tech that allows for breakless connection across a site. I have deployed it myself and it works well, but it's well out of the price range of most.

  • I see, that is pretty much what we do right now and it doesn't work very well. Keep a single connection alive is not really important but right now when you move from one floor to another the clients (Mac OS X ML) just seeks for the wireless network and you end up with an exclamation mark on the wireless connection. You have to wait a couple of minutes and turn off and on the wireless connection before you can get online again, really weird. But maybe it's setup in the wrong way. Right now all three is connected to our network in the WAN port and all of them is setup to "Create network". – Daniel Johansson Sep 18 '12 at 12:56
  • Each access point has it's own external IP address? You should plug each access point in to your internal network, not in to WAN, and configure them as such, then they will act as access points to your existing network, not routers in their own right. Please give us as detailed a description as possible of your current network, including all access points, switches, routers, IP address ranges etc and I'll see if I can be more precise. – Alex Berry Sep 18 '12 at 13:24
  • One central router/fw so the APs is only supposed to act as bridges into the LAN. So I think we'll try to switch the APs to connect to the network using the LAN ports instead of WAN ports. Don't know why they used the WAN port in the first place when they set it up or if that even matters. I'll try to set one of them to create a network and then the two others to extend this network all of them connected to the network using the lan ports. – Daniel Johansson Sep 18 '12 at 13:59
  • You only need to set them up to extend the network if at the far end they don't have ethernet access, if they do then just set them up as standalone access points with the same name, they'll work fine. – Alex Berry Sep 18 '12 at 14:17
  • I see, the problem is that they don't work fine at the moment, that's our current setup. As I explained above the Mac client just seeks for the network and can't get a dhcp lease for a very long time when you switch floors/APs. Maybe this is because they're connected using the WAN port but that shouldn't be the problem as everything else works fine. – Daniel Johansson Sep 18 '12 at 14:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.