Have an Ubuntu server here with several Samba shares for Windows machines.

Have multiple Windows machines which authenticate with samba to group shares and one public share. All working perfectly and have been for many years.

Recently my Manager changed a setting in smb.conf to get a Mac working, I believe it was the security = setting. It now reads security = user. The shares have valid users = set.

We have a public facing Windows XP PC which is allowed access to the Public share, but when attempting to access the group shares users should be prompted to authenticate. The local user account this PC is using is not setup in Samba and it opens the Public share successfully.

How it used to work

Previously I had mapped drive letters to the group shares, had provided the correct user account authentication yet disabled 'Reconnect at logon' so the machine prompted with an authentication box whenever a user from a specific department wanted to access their data. A 'normal' shortcut to the network location would not work (username was 'greyed out Guest').


Now since the smb.conf file change the previous 'mapped on request & authentication' drive letters are no longer accessible - a logon box is prompted but no account details will authenticate. No other 'workarounds' (I consider my previous to be such) will work.

Is this a Samba limitation or something within XP that now doesn't work after the smb.conf change?

  • I'm aware of having to map the Guest accounts together al-la: serverfault.com/questions/211128/… – HaydnWVN Sep 18 '12 at 13:53
  • I don't have a /etc/samba/smbusers file to add nobody = guest, All of the group shares have valid users = set with Map to guest = Bad User set. – HaydnWVN Sep 18 '12 at 14:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.