I have looked into this error and it seems that it hasn't been discussed yet - or at least I can't find any information relating.

I'm having issues transferring files, usually larger files over a couple of hundred MB.

Here is the setup:

  • QNAP 410 as iSCSI Target with multiple LUNs. (CRC is turned on (Data Digest and Header Digest)
  • Server 2003 with iSCSI Initiator version 2.08 - build 3825

(I'm copying files from anothe machine to shares on Server 2003 => into TrueCrypt volume ergo onto the NAS)

I have mounted the LUN and formatted it with TrueCrypt using NTFS (Full format, not a quick one).

What happens is some files, mainly RAR/Compressed files, appear as if they copy but fail. I've tested this in a number of ways and can repeat the process every time.

So I thought to check transfer over iSCSI without TrueCrypt in between, a plain NTFS format - no problem at all.

So it would seem TrueCrypt is at least part of the problem here.

I haven't tried copying directly from the server yet, I will try that. I also haven't tried it without CRC but fail to see how that would affect this. I will update with my findings later.

In the meantime does anyone have any ideas as to what could be wrong?

Thanks for your time.


I copied a set of files, the ones I was having issues with, to the server then from there I copied those into two places within the TrueCrypt volume (Mounted on the NAS).

  1. A seperate directory create in the root of the volume
  2. The same initial directory I was using in the first instance

Both worked fine. So it now seems clear that this is a link between TrueCrypt, iSCSI and Windows Shares.

I say this because I originally setup the whole system using TrueCrypt volume files, not iSCSI. I changed it as it didn't suit my requirements - day wasted as well. While I had this setup though I copied my entire file set to the volume files and all files copied without error - over the network, from a pc, to the server where TrueCrypt had the volume files mounted from the NAS.

I didn't bother turning off CRC on the iSCSI system as I highly doubt that is the cause in light of this finding.

So any ideas?

1 Answer 1


So after a lot of testing I have decided to answer my own question.

According to Truecrypt documentation they do not support this kind of setup, using iSCSI. I get it - so many things can go wrong but shouldn't this be something that is tested and supported?

But long story short, my intended setup works on Server 2008 (RC2) perfectly so it would seem it is localized to Server 2003 (or it could be more specifically a VM running Server 2003). It is much faster too with transfer speeds over iSCSI, not sure if that is directly related but figured I'd put it out there.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.