5

Occasionally, a computer account can lose its secure channel to a domain controller.

How can secure channel be reset without rebooting the computer?

The computer in question is a clustered SQL Server running Server 2008 R2 in a 2008 R2 Functional Level Active Directory domain and forest.

3

I've had some instances where a machine will decide to use an off-site domain controller (elsewhere on our WAN) as it's logon server and map offsite network drives instead of local ones; that can be resolved by resetting the secure channel directly:

nltest /sc_reset:<domain>\<domain controller>
5

nltest.exe can be used to check the channel and attempt to reset it.

nltest.exe /sc_verify:<fully.qualified.domain.name.here>

If that does not do it, you can restart the netlogon service (I mainly use PowerShell, so I'll give an example of that).

Get-Service netlogon | restart-service
nltest.exe /sc_verify:<fully.qualified.domain.name.here>

I ran the nltest command after restarting the service to validate that the secure channel was back in operation.

If you've made some network changes (IP Addresses, changing hardware, virtualizing, etc..) you might want to flush your dns cache and clear your arp table before running the above commands.

ipconfig /flushdns
arp -d *
Get-Service netlogon | restart-service
nltest.exe /sc_verify:<fully.qualified.domain.name.here>
0

UPDATED for new versions of powershell

Open PowerShell AsAdministrator

Test-ComputerSecureChannel  -Verbose

If False then run:

Test-ComputerSecureChannel -Repair -Server PDCEmulatorName -Verbose

If repaired you will see message, if it fails then try adding a credential

Test-ComputerSecureChannel -Repair -Server PDCEmulatorName -Credential Domain\UserName -Verbose
  • This worked for me. I bet the other answers would work too, but they didn't show how to specify the credentials – Mike Caron Feb 1 '17 at 17:42
  • Repair failed for me. I had to disjoin it from the domain (assign to the WORKGROUP workgroup), reboot, reset computer account in AD (VERY important! - will eventually happen again if you miss this step), log in with local Admin, rejoin to domain with domain admin account, reboot. – vapcguy Sep 28 '17 at 14:17

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.