1

Is there a way to change default TCP/IP new connection timeout ?

In earlier Windows, timout value was stored in registry, as said here:

Which is the default TCP connect timeout in Windows?

But this is not true for Windows 7

4

But this is not true for Windows 7

It is. KB 170359 How to modify the TCP/IP maximum retransmission timeout:

Change the following key in Windows (2000, XP, 2003, Vista, 2008, 2008 R2, Windows 7): HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters

Value Name:  TcpMaxDataRetransmissions

[...]

Change the following key in Windows (2000, XP, 2003, Vista, 2008, 2008 R2, Windows 7): HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\ID for Adapter

Value Name:  TCPInitialRtt

[...]

Article ID: 170359 - Last Review: February 14, 2012 - Revision: 6.0

APPLIES TO

[...]

  • Windows 7 Professional
  • Windows 7 Ultimate
  • Windows 7 Enterprise

[...]

4
  • This seems to have no effect on my Windows 7 Pro. I've added and changing TcpMaxDataRetransmissions to 32 (0x20), and it still takes only a couple of seconds before active PuTTY connections timeout after I briefly disable routing through sysctl net.inet.ip.forwarding=0 on my router. Doing tcpdump on the router reveals that there are only about 8 packets sent before the connection times out, not the supposed 32. Such brief outages don't affect active connections on OS X. superuser.com/questions/529511/…
    – cnst
    Jan 8 '13 at 20:52
  • 1
    Actually, it worked after I've rebooted! Nothing ever changes in Windows! Seems like you have to reboot, and the setting has no effect on either old or new connections if you simply edit the registry without rebooting!
    – cnst
    Jan 8 '13 at 22:14
  • confirmed that this does not work on Windows 7 Premium edition as a string, dword, or qword value. (restarted computer after each change) Aug 19 '16 at 16:16
  • @user3338098 "Home Premium" is neither "Professional" nor "Ultimate" or "Enterprise", so I suspect this is working as designed.
    – the-wabbit
    Aug 24 '16 at 10:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.