We had a 3-drive Windows Server 2008 R2 RAID-5 fail (operating in redundancy mode):

  • WDC 1 TB
  • WDC 1 TB
  • WDC 1 TB

We removed the failed hard drive, and put a WDC 1 TB drive (that we had standing by) into the machine.

When launched, Disk Manager, asked permission to "initialize" the disk as either:

  • Master Boot Record (MBR)
  • Guid Partition Table (GPT)

We initialized the disk as GPT, converted it to dynamic, and tried to use the Repair Volume command - except it was greyed out. (which is a terrifying thing on a failed production server hosting 3 virtual servers)

i tried from the diskpart command line tool. First we look for our RAID-5 volume that is in Failed Rd mode:

DISKPART> list volume

  Volume ###  Ltr  Label        Fs     Type        Size     Status     Info
  ----------  ---  -----------  -----  ----------  -------  ---------  --------
  Volume 0     E   VMs (Raid5)  NTFS   RAID-5      1863 GB  Failed Rd
  Volume 1     D                       DVD-ROM         0 B  No Media
  Volume 2         System Rese  NTFS   Partition    100 MB  Healthy    System
  Volume 3     C                NTFS   Partition   1862 GB  Healthy    Boot

There, Volume 0. Make that our active context:

DISKPART> select volume 0

Volume 0 is the selected volume.

Now we need to find the disk we will be repairing the volume with:

DISKPART> list disk

  Disk ###  Status         Size     Free     Dyn  Gpt
  --------  -------------  -------  -------  ---  ---
  Disk 0    Online          931 GB      0 B   *
  Disk 1    Online          931 GB   931 GB        *
  Disk 2    Online         1863 GB      0 B
  Disk 3    Online          931 GB      0 B   *
  Disk M0   Missing            0 B      0 B   *

The disk with 931 GB free, Disk 1. Now we just need to repair the volume:

DISKPART> repair disk=1

Virtual Disk Service error:
The size of the plex member is invalid.

The solution was very subtle, and a horrible design idea by Microsoft.

The two original Western Digital Caviar Black 1 TB drives were listed as 931.51 GB:

enter image description here

But the new disk was 931.39 GB (120 MB to small) - even though the drives are the same size.

In a flash of inspiration i realized that Guid Partition Table might take up more space than a Master Boot Record partition. We converted the drive back to MDR.

The drive then appeared to be 931.51 GB, and the Repair Volume option was no longer greyed out.

So, when Disk Manager tells you nothing about what the problem is - it might because there is no drive large enough to act as a replacement. And The size of the plex member is invalid. might mean that the drive is not large enough to hold the needed volume.

i especially liked the part where Disk Management told us nothing at all.

  • If this is resolved, please mark it as such by clicking on the tick mark so that it turns green. Thanks! – Michael Hampton Jul 20 '14 at 9:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.