I have sql server express 2012 installed on windows 2008, locally everything works just fine i can connect via tcpip and named pipes. Remotely i can connect with ssms only using named pipes. By remote i mean within the same LAN, they are plugged into the same switch.

I have tried disabling the firewall on both sides to eliminate blocking traffic. i have toggled the tcpip setting on and off (i read somewhere that they got it working just but flipping them off and back on). I have double/triple checked all the settings that i'm aware of and everything seems to be correct.

  • Tcp is enabled
  • Tcp port is set to 1433, udp port is set to 1434
  • Server has static ip
  • Start up log says: Server is listening on [ 'any' 1433].
  • Firewall rules are in place

Any suggestions on things that i can look into? i have really just run out of ideas.

EDIT: I used to have a copy of sql server 2008 installed on this box before i switched over to 2012. I uninstalled 2008 and then installed 2012 express; not sure if this changes anything but its another part of the puzzle.

EDIT #2: Here is the error message that i from a .net application that is trying to connect remotely.

A connection was successfully established with the server, but then an error occurred during the pre-login handshake. (provider: SSL Provider, error: 0 - The wait operation timed out.)]

EDIT #3: it looks like this is something that breaks when you install visual studio 11 or more likely .net 4.5, at least for some people; which i just did as well. Connection error after installing VS 11 And some more details

  • Might look at this question: stackoverflow.com/questions/11278114/… – user47078 Sep 23 '12 at 4:13
  • @ShawnMelton thanks, i found this and went over it as well, but i still tried it again just now with no luck. – YetAnotherDeveloper Sep 23 '12 at 5:05
  • Have a look at this answer: stackoverflow.com/a/11853321 – Jon Seigel Sep 24 '12 at 16:53
  • When you say "remote"... how remote is "remote"? Is the box at a services provider like RackSpace? It is over a WAN link? Or by remote do you just mean from your PC to a server on the LAN? – Mark Sep 27 '12 at 13:38
  • 2
    Any hope of getting a quick summary of your solution? Answering your own question and closing it will help others. – Mark Oct 18 '12 at 17:13

Check the TCP IP setting properties in COnfiguration Manager, the IPAll should set the dynamic to be empty and static to 1433.

| improve this answer | |
  • What is the "IPAII?" – Warren P May 15 '13 at 16:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.