I have a Brother 7360N Network Printer connected to a TPLINK Router over an Ethernet cable.

My desktop, running Windows 8 is connected to the TPLINK Router over an Ethernet cable. A ROKU device is connected over Ethernet.

The TPLINK Router is setup as "Client Bridge (Routed)" wirelessly connected to my other router, a Linksys 3000. Both routers are on DD-WRT. This Linksys router is connected to ISP's Cable Modem and DHCP is enabled. I have also hard-coded some PC and Brother's MAC address to fixed IP address. Two laptops are connected to Linksys wirelessly.

A Physical Windows2008R2 Server connected to Linksys through CAT-5. This server hosts multiple Hyper-V machines including a Windows2003 Virtual PC which is a Domain Controller running DNS.

Network diagram


From my Windows 8 desktop I cannot ping or access the Brother printer, neither ping ROKU. Whereas I can ping Brother printer and access its website from W2K8 Physical machine, any virtual machine and the two laptops.

If I disable Windows 8's Network card, plug in a USB WiFi Dongle, connect to Linksys, I can ping Brother, access its website, ping Roku all works fine. I just cannot ping/connect to the Brother printer from desktop when connected to TPLINK through Cat-5. Both Brother and desktop connected to same TPLINK and they can't see each other.

UPDATE: I connected one of the laptop to the TPLINK using a CAT-5, turned off WiFi, and can't ping/access website of the printer. Neither it can ping the Win8 PC which is also connected to TPLINK. Win8 Machine can't see the laptop. So the TPLINK is the problem, somehow. TPLINK cannot connect to it's own devices to each other. Anything connected to Linksys can see the printer, Win8 machine and the Laptop. Any idea?

Route Print:

Interface List
 21...d0 27 88 d2 b7 13 ......Realtek RTL8168D/8111D Family PCI-E Gigabit Ethernet NIC (NDIS 6.20)
 16...00 50 56 c0 00 01 ......VMware Virtual Ethernet Adapter for VMnet1
 18...00 50 56 c0 00 08 ......VMware Virtual Ethernet Adapter for VMnet8
  1...........................Software Loopback Interface 1
 15...00 00 00 00 00 00 00 e0 Microsoft ISATAP Adapter
 17...00 00 00 00 00 00 00 e0 Microsoft ISATAP Adapter #2
 14...00 00 00 00 00 00 00 e0 Teredo Tunneling Pseudo-Interface
 19...00 00 00 00 00 00 00 e0 Microsoft ISATAP Adapter #3

IPv4 Route Table
Active Routes:
Network Destination        Netmask          Gateway       Interface  Metric
     20         On-link    306         On-link    306         On-link    306         On-link    276         On-link    276         On-link    276         On-link    276         On-link    276         On-link    276         On-link    276         On-link    276         On-link    276         On-link    306         On-link    276         On-link    276         On-link    276         On-link    306         On-link    276         On-link    276         On-link    276
Persistent Routes:

IPv6 Route Table
Active Routes:
 If Metric Network Destination      Gateway
  1    306 ::1/128                  On-link
 16    276 fe80::/64                On-link
 18    276 fe80::/64                On-link
 21    276 fe80::/64                On-link
 16    276 fe80::1463:818a:9fd1:8547/128
 18    276 fe80::9899:1b44:c0de:37a/128
 21    276 fe80::f0e2:8da7:e9c5:f122/128
  1    306 ff00::/8                 On-link
 16    276 ff00::/8                 On-link
 18    276 ff00::/8                 On-link
 21    276 ff00::/8                 On-link
Persistent Routes:

The documentation for dd-wrt Client Bridge mode clearly warns:

This will not work reliably under Atheros devices. Many problems occur, so stay away from it.

Your WR-841ND is an Atheros device, ergo you should not be using "Client Bridge" mode. Fortunately, your network is simple enough that transitioning to a supported mode should not be too much of a hassle.

You have two options for switching to a supported configuration:

  1. Keep your existing hardware, but configure it for "Client Mode" instead of "Client Bridge". You would need to move the IP addresses of the devices plugged into your WR-841ND into a different subnet (e.g. and configure DD-WRT to provide routing between the two subnets. This is a little bit more work than setting up a transparent bridge, but it's not too difficult. Either way, your first priority needs to be moving away from a configuration that is known not to work.

  2. Switch to a supported Broadcom device and try "Client Bridge" mode again.

  • Using wireless client bridge mode would prevent devices plugged into the Ethernet ports from talking to each other? – Michael Hampton Sep 26 '12 at 6:03
  • 1
    @MichaelHampton Haven't we all seen much crazier #%&@ than that when running $[thing] in $[unsupported_configuration]? – HopelessN00b Sep 26 '12 at 15:39
  • Yes you are right, I missed that part. The "Client" mode must be hard, tried it - didn't work. Should I use a sub-net of main router, like to 32 remains in Main Router, and to 96 remains in this "Client" router? I haven't tried this setup yet. Or should they be in separate network, like 192.168.0.xxx=main, and 192.168.1.xxx=Client? I tried this setup, did not work. – Mehdi Anis Sep 27 '12 at 3:41
  • Yes, they would need to be separate networks e.g. and Also, dd-wrt would need to be configured to route traffic between the two networks, e.g. the Linksys device would need to know that traffic bound for needs to go via next hop, and the TP-link router would need to have a default route for internet traffic with a next hop of – Skyhawk Sep 27 '12 at 6:18
  • @Miles Erickson: I think best to get a new router. Do you think Linksys 3200 will do it (Broadcom chip/DD-Wrt'ble) ? Kind a pricey. Any other $50'ish router that you suggest? Thanks. – Mehdi Anis Oct 3 '12 at 20:11

I suspect:

  • Bad switch port on the TP-LINK
    • Or you put the Windows 8 box in a wrong VLAN by mistake
  • Bad Cat-5 cable
  • Bad NIC in the desktop machine
    • Or a problem with the NIC drivers

Since you've updated your question, I'll update my answer:

  • The TP-LINK is pretty clearly the cause of the problem here. I would reset it to stock settings and reconfigure the wireless client bridge. I presume you are running an alternate firmware such as DD-WRT, as the OEM firmware doesn't support client bridge.
  • TP-LINK was my primary router b4 I bought Linksys, and worked perfect. Even the TPLINK port is BAD, pcs/laptops connected to Linksys could not see the printer - but they can see printer, access its website, print. Bad Cat5 or Bad Nic on Desktop ruled out, as desktop is using internet, lan shared folders just fine. Nic Drivers: That might be a problem, over the time I did so many things on this desktop, virtual-pc, vmware etc installed many protocols virtual-lan cards. Is there a way to reset all that? – Mehdi Anis Sep 26 '12 at 4:21
  • Before you reinstall Windows, you should still check the switch port. – Michael Hampton Sep 26 '12 at 4:27
  • Ports are OK, otherwise internet wouldn't work either on Desktop. I tested all the ports of TPLINK, internet/shared folder works on Win8. And Other PCs connected to Linksys can see the printer. It's only device connected to TPLINK cannot see the printer. – Mehdi Anis Sep 26 '12 at 5:03
  • It's pretty clear, then, that the problem is isolated to the TP-LINK. Factory reset it and reconfigure it. – Michael Hampton Sep 26 '12 at 5:09
  • Factory RESET to TPLINK's Firmware or or to current DD-WRT's firmware? I am running DD-WRT on both routers. There is no other setting on tplink except setting it up as Client Bridge (Routed) setup. – Mehdi Anis Sep 26 '12 at 5:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.