1

So the context

  1. Django1.4.x doesn't support postgis2.0 (https://code.djangoproject.com/ticket/16455)
  2. Postgres9.2x doesnt support postgis1.5 (http://trac.osgeo.org/postgis/wiki/UsersWikiPostgreSQLPostGIS)

So to get the 3 playing together nicely, I have to go django1.4 with postgis1.5 and postgres9.1x.

The problem is, installing postgis15

$ brew tap homebrew/versions
$ brew install postgis15

tries firstly to install postgres9.2.1 as a dependency which I dont want. In anycase, I still get the following error

nai@nyc ~  $ brew install postgis15
==> Downloading http://postgis.refractions.net/download/postgis-1.5.3.tar.gz
Already downloaded: /Users/nai/Library/Caches/Homebrew/postgis15-1.5.3.tar.gz
==> ./configure --with-projdir=/usr/local --with-pgconfig=/usr/local/Cellar/postgresql/9.2.1/bin/pg_config
==> make
                num2_tuples = reltup->reltuples;
                              ^
4 errors generated.
make[1]: *** [lwgeom_estimate.o] Error 1
make: *** [postgis] Error 2

Im completely stuck as to how to get those versions working together nicely using brew!

1 Answer 1

1



One solution is to install through the official postgresql installation package:

1) Go to http://www.enterprisedb.com/products-services-training/pgdownload#osx
2) Download the version 9.1.6 of postgresql
3) After the installation, run the Stack Builder
4) Stack Builder: select your postgresql installation and click next
5) Select Categories -> Spatial Extensions -> PostGIS 1.5 for PostgreSQL 9.1 v1.5.3-1
6) Finish the installation.

Perhaps you have to uninstall your previous installation using homebrew.
Regards.

Not the answer you're looking for? Browse other questions tagged or ask your own question.