I've just installed TFS2012 and am trying to create a new project in the default collection via Visual Studio 2012 but I keep getting this error message:

TF218027: The following reporting folder could not be created on the server that is 
running SQL Server Reporting Services: /TfsReports/DefaultCollection. The report 
server is located at:
http://<servername>/Reports. The error is: The permissions granted to
user '<domain>/grandmasterflush' are insufficient for performing this operation.. 
Verify that the path is correct and that you have sufficient permissions to create the 
folder on that server and then try again.

I've checked the permissions and my user is a member of the Project Collection Administrators and the Project Collection Administrators group has the 'Create new project' permission set to allow.

The only thing I think it might be is that the user that I created during installation for the Sharepoint access and reports viewing does not have permission to write to the reports folder, however if I select "Do not configure a SharePoint site at this time" then I still get the error messages. I can't find the reports folder to check the permissions either.

TFS is using an instance of SQL 2012 that was already on the machine when TFS was installed.

Can anyone see what I'm doing wrong please?

EDIT: If I try and create the project in VS when I'm logged in as administrator it lets me. I'm a bit confused by this as I would have thought that the server would run any attempts to create project folders as administrator, not as me.

RESOLUTION: Following on from Richard's answer, I browsed to http:///Reports/Pages/Folder.aspx and made viewed the "Security" option for 'TfsReports' and ensured that the AD group I had connected had the 'Team Foundation Content Manager' permission. This allowed me to start creating a project but didn't finish the wizard (see my comment to Richard's answer). It was only after I'd added the AD group with associated permissions to the 'Tfs2010OlapReportDS' and 'TFS2010ReportDS' objects in the folder that it fully worked.

I hope this post helps someone else and saves them the wasted hours I've just had!

  • Actually saved my efforts. Thanks GrandmasterFlush for useful UPDATE. – user242052 Sep 12 '14 at 8:50

You need to set permissions on SQL Server Reporting separately from TFS itself.

TFS, Reporting Services and SharePoint all have independent permissions. The group "Project Collection Administrators" is internal to TFS and thus only gives access to the TFS functions, not the functions it uses on other servers.

The recommended approach is to create groups in AD (eg. "TFS Collection X Admins") in AD; and then use that group to give permissions in each of TFS, SharePoint and Reporting Services.

  • Thanks Richard, I've created this group and after a lot of battling managed to get past that error. However, I now get: Plugin error text: “TF249061: You cannot access the following report item: /Tfs2010ReportDS. Access was denied because your account does not have one or more permissions required to access this item.” – GrandMasterFlush Sep 27 '12 at 14:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.