3

I have created a LBFO team for use in storage and would like to enable Jumbo Frames. If I do, "Get-NetIPInterface" I get the result:

NlMtu(Bytes) 1500

If I execute, "Set-NetIPInterface -InterfaceAlias "Storage Team" -NlMtuBytes 9000 -AddressFamily "IPv4"" and do "Get-NetIPInterface" again, the MTU still reports as 1500.

  1. Do LBFO Teams support jumbo frames?
  2. If so, is this the correct method to set it? "Get-NetAdapterAdvancedProperty" doesn't seem to have a jumbo frame or MTU setting.
  • Are you using this with the MS iSCSI Initiator? If so, you probably want MPIO, not teaming. – Doug Luxem Oct 15 '12 at 19:52
  • We're using the NICS for SMB for our Hyper-V cluster. – CCCPSpy Oct 15 '12 at 23:58
3

From what I can see the LBFO team inherits the MTU set on the interfaces. So if you use the Set-NetIPInterface -NlMtu on the interface prior to using the LBFO commands to create or add them to a team then you should end up with a team which can use jumbo frames.

Be warned though the MTU is set per address family and also probably requires you to change an advanced adapter setting in the Configure -> Advanced section of the interface properties and as far as I know these are not exposed to the PowerShell interface.

1

Just wanted to add something to this question - I came across the same issue:

  1. A LBFO team was created initially when all underlying adapters were at 1500 MTU
  2. There was a requirement to enable jumbo frames on this team
  3. After enabling jumbo frames on the underlying NICs, jumbo frames were still not enabled on the LBFO team interface

My fix was to simply restart the LBFO team adapter:

After restarting the LBFO interface with the PowerShell command Restart-NetAdapter, using the command Get-NetIPInterface now correctly showed the 9000 MTU, and jumbo frames tested with ping -f -l 8000 x.x.x.x worked correctly.

An alternative is to right click Disable & Enable on the LBFO team interface.

Each underlying NIC does not have to be restarted because they reset when you apply the jumbo frame setting. Since the LBFO adapter never understands it needs to reset to apply the MTU change, it must be done manually.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.