2

Running the Best Practice Analyzer on a Windows Server 2012 RTM (this virtual server runs on a hyper-v host), I receive two configuration warnings.

enter image description here

  • Enable Receive Side Scaling (RSS) on a network adapter

    I run the following PS cmdlet:

    Enable-NetAdapterRss -Name *

    output:

     Enable-NetadapterRss : The request is not supported.
    
     At line:1 char:1
     + Enable-NetadapterRss -Name *
     + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~
          + CategoryInfo          : InvalidOperation: (MSFT_NetAdapter...1E300D0AB920}"):ROOT/StandardCi...rRssSettingData)
          [Enable-NetAdapterRss], CimException
          + FullyQualifiedErrorId : Windows System Error 50,Enable-NetAdapterRss
    

    Next, Since, the PS cmdlet didn't work, I go to the network adapter settings. And, offcourse I don't see any option called Receive Side Scaling.

    enter image description here

  • Enable IPsec Task Offload v2 (TOv2) on a network adapter

    For this one, I go the network adapter properties (see the screen shot above), there is an option called IPSec Offload. It is set to Auth Header and ESP Enabled. But, BPA still complains that this settings is not enabled.

Do I have to enable these configuration settings on the hyper-v host's network adapter? I would like to know how I can configure these two options.

Update:

I ran the cmdlet Ryan mentioned below. Here is the output:

enter image description here

0
3

The following must occur to get rss and tcp offload in a hyper-v vm:

  • Host must have them enabled on the appropriate physical nics
  • The virtual nics must be synthetic nics, not emulated
  • In hyper-v manager, the virtual nics must have Enable virtual network optimizations turned on
  • Rss and tcp offload will automatically be turned on in the guest now
3
  • This was my guess and it looks like a promising solution. I will give it a try and let you know. – H A Sep 28 '12 at 18:34
  • Some research brought me to this page. You can check if your host's physical adapters are even capable of RSS with Get-SmbServerNetworkInterface. If they're not capable of RSS and you're already running the best drivers for them, then you're out of luck. – Ryan Ries Nov 10 '12 at 18:10
  • @Ryan I ran the cmdlet you mentioned. It shows RSS capable false. See screenshot in the update above. – H A Jun 12 '13 at 21:14
2

Enable on all adapters

    PS C:\> Enable-NetAdapterRss –Name *

Source: https://technet.microsoft.com/en-us/library/jj130859(v=wps.630).aspx

0

For RSS you can run the following from a command prompt:

netsh int tcp set global rss=disabled

1
  • I did run this command (netsh interface tcp set global rss=enabled) because I want to enable rss. The output is OK. BPA still complains that I need to enable rss for the network adapter. – H A Sep 28 '12 at 18:00
0

For anyone looking for the answer, in Hyper-V if you only assign a single vCPU to a VM RSS and TOv2 are not presented to the guest OS via the virtual NIC adapter (for obvious reasons).

So if TO is working correctly in other VMs then you can get rid of the BPA warnings by adding more vCPU cores to the guest OS. I would recommend that you ignore it however, as it is inefficient to assign more then 1 core to a VM that does not need it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.