I recently had a laptop hard drive crash on me and am trying to rescue some of the data on the original drive.

As such, I've extracted my failed hard drive and installed it in a USB enclosure. I've been successful retrieving some data but am getting "Acces is denied." popups whenever I try to access files under my "Documents and Settings\username" folder.

What's strange (to me) is I can access files under my girlfriend's "Documents and Settings\girlfriend-username" folder but cannot access the files under the username directories.


8 Answers 8


You may wish to try one of the Linux-based rescue CDs that you can boot from. These may help work around permissions errors, if in fact the pop-ups you see are generated by permissions errors and not by filesystem corruption.

See the answers to the SF question Favorite system recovery Live CD?.


Have you tried SpinRite?

Steve knows his stuff, and SpinRate has saved my bacon before. The tool is very mature. You can purchase and download at grc.com. I am not a shill, just a customer.


Make sure you are logged on as an administrator on the machine you are accessing the drive from. Then right click the folder you are trying to access and select properties. Click on the security tab. Click on the advanced button in the lower right hand corner. That should bring up the Advanced Security Setting for filename box. Click on the owner tab. Place a check mark in the Replace Owner on subcontainers and objects box. Click OK and click OK. This will make your current user owner of the files and allow you to access them.

  • I have personally had to do this ( I believe the steps are correct ) to "take ownership" of files on a drive - the situation was similar as well. I would try this before inserting a LiveCD, but I may not 'know my stuff' as well as others. May 11, 2009 at 18:02

Windows give the option to encrypt the user directory when setting it up. There is a chance that this is what is happening.

The second is that the user directory has NTFS permissions denying access. Try right clicking, properties, security, advanced, ownership, and take ownership of this and all sub folders. They try copy again.


This sounds like a permissions issue rather than filesystem corruption or hardware failure.

However - If it is hardware failure - don't laugh - we have had surprising success by putting the hard drive in a bag in the freezer overnight, and re-connecting in the morning.

I'm not sure what this does, and it only lasts a short while, but it has allowed us to recover data from an otherwise unreadable hard drive when no other methods have worked.

  • I've also had success with turning the drive up-side-down. This can temporarily reset a crashed read/write head.
    – Scott
    May 4, 2009 at 23:09
  • I have flipped and frozen a drive that was suffering from "clicking" and failure to boot. It would run for a few minutes (4-8, after about 30 minutes in the freezer), just long enough to copy important files off... tho', indeed, these errors would have to be "Hardware" problems for this to have any effect. May 11, 2009 at 18:05

The best software for recovering files from a drive is Photorec

PhotoRec searches for known file headers. If there is no data fragmentation, which is often the case, it can recover the whole file. Photorec recognises numerous file format including ZIP, Office, PDF, HTML, JPEG and various graphics file formats. The whole list of file formats recovered by PhotoRec contains more than 180 file extensions (about 100 file famillies).

  • I've personally had good results with Zero Assumption Recovery www.z-a-recover.com when dealing with damaged CF cards. Like PhotoRec, they look for meaningful data rather than depending entirely on filesystem structures. They can't do nearly as much with file types they don't already know about, however.
    – RBerteig
    May 5, 2009 at 3:25

just an addendum ... if you go to properties of the folder(s) and you do not see a "security" tab that allows you to change owner, you need to turn off Simple File Sharing. This is in the folder options - way down on the bottom of the list of options. on xp if "simple file sharing" is on, you can't see the area that allows you to change owner.



Another program along the lines of Photorec is Foremost.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.