I have a Dell PE 1950 with 2 SATA drives in a software RAID1. OS is CentOS 5.5 (2.6.18.x). Starting this afternoon we received HW errors (something on the bus is bad, E171F) and the machine became unresponsive. We hard booted and it came back up for about 5 hours but then it happened again.

I'm trying to figure out our options. Unfortunately we do not have similar hardware but I have a small desktop that I can use. I was contemplating putting one of the drives into the desktop and then starting it up. My goal was to then P2V it using Vmware converter but apparently the free v5.x doesn't support hot cloning/converting on a RAID volume, only the Enterprise 4.x version of Converter does.

My questions are:

  1. Is putting a single drive out of a RAID1 pair into another piece of HW is safe? Based on my research and understanding it appears to be but would like confirmation.
  2. Is there any work around to the Vmware Converter not supporting RAID volumes during a hot clone/convert session?
  3. Are there other options I'm overlooking?
  • By "software raid" do you mean Linux MD using mdadm? Yes, that is safe if the RAID was clean when the server shutdown. – Andrew Sep 29 '12 at 5:00
  • Is there a reason you can't set up another machine and restore from your backup? – John Gardeniers Sep 29 '12 at 10:11

You could try to source a similar server. Dell PowerEdge 1950 systems are/were common, and finding like hardware shouldn't be an issue in an urban or metropolitan area.

The error you have is a PCIe bus error. Dell's instructions are to:

Remove and reseat the PCI expansion cards. If the problem persists, see Troubleshooting Expansion Cards. If the problem persists, the riser card or system board is faulty.

These are all repairable and serviceable components, so it may make more sense to reach out to a local resource to help source the parts. Someone has them in stock! Try to fix the source issue first. I think moving drives or attempting a P2V could be a little messy.

If the system stays up long enough, you could simply copy the critical data off of it. But this is by no means an unfixable situation.

  • 1
    I have had exactly the same error code on my 1950 and removing the scsi expansion card solved it. – boburob Sep 29 '12 at 6:30
  • You can also purchase a 2950 or 2900 if you wish - they all use the same drivers - dell mentioned on their press release that all models could share common images. – Robin Gill Sep 29 '12 at 7:34
  • Did this solution work? – ewwhite Oct 2 '12 at 22:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.