I just updated kernel for my Linux:

[root@localhost ~]# cat /etc/redhat-release 
Scientific Linux release 6.1 (Carbon)
[root@localhost ~]# uname -a
Linux localhost.localdomain 2.6.32-131.0.15.el6.x86_64 #1 SMP Tue May 10 15:42:40 EDT 2011 x86_64 x86_64 x86_64 GNU/Linux
[root@localhost ~]# 

last few entries from /var/log/messages:

Oct  1 10:22:10 wcmisdlin02 wall[21689]: wall: user root broadcasted 1 lines (8 chars)
Oct  1 10:22:40 wcmisdlin02 NetworkManager[1866]: <info> kernel firmware directory '/lib/firmware' changed
Oct  1 10:22:43 wcmisdlin02 yum[21626]: Updated: kernel-firmware-2.6.32-279.9.1.el6.noarch
Oct  1 10:22:53 wcmisdlin02 yum[21626]: Installed: kernel-2.6.32-279.9.1.el6.x86_64
Oct  1 10:23:05 wcmisdlin02 yum[21626]: Installed: kernel-devel-2.6.32-279.9.1.el6.x86_64
Oct  1 10:23:07 wcmisdlin02 yum[21626]: Updated: kernel-headers-2.6.32-279.9.1.el6.x86_64


[root@localhost ~]# tail /var/log/yum.log | grep "^Oct 01"
Oct 01 10:22:43 Updated: kernel-firmware-2.6.32-279.9.1.el6.noarch
Oct 01 10:22:53 Installed: kernel-2.6.32-279.9.1.el6.x86_64
Oct 01 10:23:05 Installed: kernel-devel-2.6.32-279.9.1.el6.x86_64
Oct 01 10:23:07 Updated: kernel-headers-2.6.32-279.9.1.el6.x86_64
[root@localhost ~]# 

and now it won't boot(, right after I'm seeing GRUB where I can select different version of kernel (I've tried newly installed one AND previous kernel) w/ same results:

Kernel panic - not syncing: VFS: Unable to mount root fs on known-block(0,0)
Pid: 1, comm: swapper Not tainted 2.6.32-279.1.1.el6.x86_64 #1
Call Trace:

I also noticed all "initramfs" files are looks like have been updated (that's probably why I can't boot into old kernel anymore too)

[root@localhost ~]# ls -al /boot/initramfs-2.6.32-279.*
-rw-r--r--. 1 root root 15227261 Oct  1 10:25 /boot/initramfs-2.6.32-279.1.1.el6.x86_64.img
-rw-r--r--. 1 root root 15227720 Oct  1 10:25 /boot/initramfs-2.6.32-279.5.1.el6.x86_64.img
-rw-r--r--. 1 root root 15227774 Oct  1 10:26 /boot/initramfs-2.6.32-279.9.1.el6.x86_64.img
[root@localhost ~]# 

any ideas?

  • Just in case, forums.fedoraforum.org/showthread.php?t=262786 talks about usb stick. – user130370 Oct 1 '12 at 16:08
  • guy was able to boot old kernel and i'm not( so not helpful – alexus Oct 1 '12 at 16:12
  • Please read before saying "not helpful" : 1st guy was able to boot old kernel. I was talking about post number 5. – user130370 Oct 1 '12 at 20:15
  • yes, I read entire thread and no I don't have any USB sticks in my computer that's why it wasn't helpful. (it's not like I downvote you or anything) I appreciate your help/input its just wasn't helpful for my issue. – alexus Oct 1 '12 at 20:59
  • btw, I also mentioned in my original post that I did tried both of kernels (including newly installed AND previous) w/out any luck – alexus Oct 1 '12 at 21:24

Kernel panic – not syncing: VFS: Unable to mount root fs on known-block(0,0)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.