I have 2 different VMware server hosts on 2 different geo-locations. one of the machines, which is located in Paris has gone corrupted and i was given the task to copy this machine from the other VMware server host which is located in London. Both machines are identical (apart from the machine's name) and the only difference between them is the geographical location of the hosts. After copying the machine's vmware folder using scp from the London host to the Paris host, in the web UI, while the host name is selected in the VM tree, i clicked Virtual Machine menu -> Add Virtual Machine to Inventory and added the newly moved machine to the host. Then I tried powering on the machine and got the message which asks me if i copied or moved the machine, i chose "moved it" and the bar which indicated the progress of powering on the machine reaches 95% and hangs until i get the following error: "Power on virtual machine" failed to complete, if these problems persist, please contact your system administrator". When i check the Events tab of the problematic machine i get this error: "VMware server cannot ifind the virtual disk "machinename.vmdk". please verify the the path is valid..." Edit: In addition to the rest of the things i've tried in order to solve the issue I've edited the xp-par-2.vmx file and edited the names of the files on all occurrences to the name of the new machine but it still gives me this error and now with the new filename: "VMware server cannot find the virtual disk "/mnt/storage/vmware/xp-par-2/xp-par-2.vmdk" although it's there. any suggestions?

  • Does the file you are having problems with have the same owner and permissions as other .vmdk files? What about the directory it's in? Oct 2, 2012 at 12:12
  • I can only compare it against the machine in the original location where i took the folder from. The permissions are identical and the user and group are root just as it is in the new location
    – Itai Ganot
    Oct 2, 2012 at 12:27

2 Answers 2


I do not know exactly, but I will try to help...

  1. If you said that you copied the VM via scp, why did you answer "moved it"?
  2. Obviously, VMware needs a virtual disk "machinename.vmdk". If you use some GUI (I suggest vSphere Client), why have you edited .vmx files manually? Why not just check VM Settings in vSphere Client before powering on the VM and see which virtual disks are configured, and which of them are missing in the VM folder?
  • 1. Well, I've tried both options, first i chose "copied it" and saw the problem, so i've removed the virtual machine and deleted the files from the file system. Then i scp'ed the files again but this time i chose "moved it" but the error's still in place.
    – Itai Ganot
    Oct 2, 2012 at 11:50
  • 2. I can't use vSphere client as this is a free version of vmware server and as far as i know the vSphere client won't be able to work the vmware server. I did check the VM setting before powering on the machine but the options i have there are very limited and i have no way to check which file is configured as the disk for the machine. None of the disks are missing from the folder - that's the issue, it keeps saying that it can't find the vmdk file even though it's there.
    – Itai Ganot
    Oct 2, 2012 at 11:52
  • 1
    @Itai, 1. If you want to remove a machine completely and totally then you should be deleting it, which doesn't entail manually deleting the VM's files. It sounds like you removed it from inventory instead of deleting it from disk. 2. The vSphere client is free, it doesn't know or care whether you're running the free version of vSphere or a licensed edition. 3. Try again. Copy the VM from one host to the other but DON'T manually muck with the files... or anything else. Try using the datastore browser to copy the VM or try Trilead VM Explorer to replicate the VM from one host to another.
    – joeqwerty
    Oct 2, 2012 at 14:17

So the right way to solve the issue as @joeqwerty suggested was to remove the machine using the vmware client and marking the "delete machine from disk" option, then I re-scp'ed the machine folder from another server, edited the conf file to reflect the name machine name and used the UI menu again in order to re-add the machine to the inventory, when prompted i chose "I moved it" and then I was able to successfully turn the machine on.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .