I am using Windows Server 2008 R2 Enterprise x64.

After installing the Hyper-V role and restarting the machine, I get a blue screen error and an immediate reboot. I have Googled the issue and tracked it down to the graphics card, so I uninstalled it, and then Windows loads fine. However, after installing the graphics driver again, the Blue Screen returns.

The graphics card is an Nvidia GeForce 8400 GS.

Does anyone know how I can resolve this issue?

  • What is the Stop code? What version of the drivers are you running? – Chris S Oct 2 '12 at 15:19

Despite you having marked the other answer as the correct answer, it is not correct. My Hyper-V host is humming along happily with an nVidia GPU the size of an acme brick in its 4U chassis.

Hyper-V does support some 3D graphics cards. RemoteFX requires a 3D card in fact. The list of supported cards is evolving every day.

You're facing a hardware/driver incompatibility, you might try making sure all your drivers are up to date, but maybe you're just running an unsupported combination of hardware right now.

Edit: Here is the small list of "Supported, Tested, Microsoft verified" video cards for use with Windows Server:


That doesn't mean that other video cards won't work, but those are the ones that've been tested by MS.

Edit: According to this MS article you also need SLAT enabled on your processor: http://technet.microsoft.com/en-us/library/ff817602(v=ws.10).aspx

  • You're right. But you should mention SLAT, without which any 3D graphics card will grind to a halt as soon as Hyper-V is enabled. – Massimo Oct 2 '12 at 16:34
  • @Ryan Ries, i unmarked the answer, and the issue was gone after uninstalling the definition of the graphics card, but this is not the best solution i guess. so you suggest to install RemoteFX cap driver only or there are any other suggestions ? – Mahmoud Saleh Oct 2 '12 at 18:23
  • @MahmoudSaleh, I've heavily revised my answer after all the negative comments, please have a look at it again. The part about SLAT is very probably the cause of your issue. – Massimo Oct 2 '12 at 18:27
  • Also, if this really was a hardware/driver issue, it would have emerged long before enabling Hyper-V. – Massimo Oct 2 '12 at 19:13
  • @Massimo Again, that's not true. Installing a hypervisor on a system deeply affects the way that system loads and uses drivers. Check out the Hyper-V section of chapter 3 in Windows Internals, 6th ed. – Ryan Ries Oct 2 '12 at 19:50

I uninstalled the display adapter definition, and used one installed by windows server automatically which is: Standard VGA Graphics Adapter, and everything works fine now.

  • ...and you're wasting a perfectly good 3d card. – Massimo Oct 3 '12 at 17:10
  • If it's causing his machine to blue screen, it's not fit for purpose so calling it a "perfectly good 3d card" is a tad overgenerous. – CadentOrange Nov 28 '12 at 17:37

Hyper-V has been long known to not play well (pun intended) with 3D graphics cards, due to its type-1 hypervisor nature, which puts the virtualization layer between the Windows O.S. and the underlying hardware; when the role is enabled, the memory translation operations required to make virtualization work don't allow 3D drivers to perform as they should; in the article I linked above, Microsoft explicitly recommends to not use 3D graphics cards with Hyper-V servers, or, if that is actually needed, to not use their card-specific drivers and instead switch to standard VGA drivers, losing all 3D acceleration capabilities in the process.

A more thorough explanation of this issue, along with a viable solution, can be found here: recent CPUs with latest-generation hardware virtualization support are able to work around this issue using a technology called SLAT, allowing to make full use of 3D graphics card on Hyper-V servers without any performance issue, and even making possible things like RemoteFX. Here you can find a list of CPUs which support SLAT.

If your CPU doesn't support SLAT, then you should definitely not try to use any 3D graphics card together with Hyper-V: if the server doesn't crash, it will have terrible video performance anytime you try to use anything even vaguely 3D-related (like Aero desktop themes).

If, however, your CPU does support SLAT, then this is probably a compatibility and/or driver issue: your card is not present in the Hardware Compatibility List for Windows Server, so it is not guaranteed to work; however, as the O.S. kernel is the same as Windows 7 x64, it should work with proper and up-to-date drivers.

The fact that you are experiencing a system crash only after enabling the Hyper-V role makes me think you are running into the issue I was talking about at the beginning of this answer, i.e. your CPU not supporting SLAT.

  • first of all i am not a sysadmin i am a developer, and what do you suggest to solve this issue ? – Mahmoud Saleh Oct 2 '12 at 15:19
  • i mean what should i do to use hyber v correctly, should i uninstall the driver definition, or should i use another graphics card, if so what type of graphics card should i use ? – Mahmoud Saleh Oct 2 '12 at 15:24
  • 1
    I find this whole thing contradictory since with the use of VDI running on top of Hyper-V you use video cards to offload the video composition to a GPU as opposed to the CPU. Not to mention that I have done it before. You may have to enable the Windows Desktop Experience feature to allow 3D video to work properly however. – Brent Pabst Oct 2 '12 at 15:36
  • 1
    Sorry, my answer was actually quite a bit too simplistic; I've heavily revised it to include missing information and move the focus on SLAT (and possibly compatibility issues). – Massimo Oct 2 '12 at 16:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.