I have searched using all kinds of variations on relevant terms and I cannot find a single other instance of someone else having this excact same problem, so I am hoping someone here may have a clue.


I installed Windows Management Framework 3.0 (KB2506143) by downloading and running Windows6.1-KB2506143-x64.msu from Microsoft.com. Once completed I rebooted my machine as requested. After rebooting and logging in, I try to run the 64-bit PowerShell command shell and it comes up for a second then goes away. The 32-bit shell seems to work fine, it is just the 64-bit one that fails.

Looking in the Fusion logs, I found:

*** Assembly Binder Log Entry  (10/4/2012 @ 1:51:48 PM) ***

The operation failed.
Bind result: hr = 0x80070002. The system cannot find the file specified.

Assembly manager loaded from:  C:\Windows\Microsoft.NET\Framework64\v2.0.50727\mscorwks.dll
Running under executable  C:\WINDOWS\system32\WindowsPowerShell\v1.0\powershell.exe
--- A detailed error log follows. 

=== Pre-bind state information ===
LOG: User = ********\*****
LOG: DisplayName = Microsoft.PowerShell.ConsoleHost, Version=, Culture=neutral, PublicKeyToken=31bf3856ad364e35, processorArchitecture=MSIL
<remainder omitted>

GacUtil reveals that there is a Microsoft.PowerShell.ConsoleHost, Version=, but not

I tried uninstalling KB2506143 (which removed MSVCRT90.dll and caused Windows Live Messenger to fail on load after rebooting again, so I ran a repair in stall on Windows Live Essentials and that fixed the Messenger problem) and then re-installing it, but nothing changed.

If it helps, here are what I think may be the relevant parts of my hardware/software environment.


  • Dell Latitude E6510, 8GB RAM
  • Windows 7 Professional 64-bit with SP1
  • Visual Studio 2010 Professional installed (includes .NET 4.0)
  • Visual Studio 2012 Professional installed
  • Microsoft Forefront Client Security

Any clues out there?

Thanks, Dave

  • Windows 7 I assume? Oct 5 '12 at 4:17
  • Did you ever have a beta version of PoSH 3 installed? Oct 5 '12 at 4:17
  • Did you attempt to re-install powershell 3?
    – Clayton
    Oct 5 '12 at 13:15
  • a) Yes, Windows 7. Sorry I meant to make that part of the "Windows Professional" line. b) No, I never installed the beta. This was my first install. c) The only way (that I know of) to install PowerShell 3 is via Windows Management Framework 3.0 (KB2506143). As noted (although I see that I did not make it clear that the KB was the same thing as the installer above), I did try uninstalling and re-installing that. No joy. Oct 5 '12 at 16:03
  • I edited the post to clarify Windows 7 and also tie the KB# with the package referenced in the first paragraph. @Craig620, thinking about it a little more, it is possible that I tried installed PowerShell 3.0 some months ago, but it would not install because at the time I did not have Windows 7 SP1 installed. So just to cover all bases, if I had installed the Beta, what would I have to do to clean up from there? Also, I do have the Windows PowerShell 2.0 SDK installed, if that makes any difference. Oct 5 '12 at 16:36

Which KB2506143 are you installing? When I google KB2506143, I get this link for download that is the "release candidate" for WMF3.0

When I google "Windows Management Framework 3.0" I get a different link that does NOT mention "release candidate".

The file sizes for Windows6.1-KB2506143-x64.msu listed on the two pages are different. If you're still running the RC try the final release.

  • Sorry, I don't get email notifications for this so I did not see your question until now. I installed the RTM version. It says nothing about RC, CTP, or anything else. Oct 29 '12 at 17:36
  • The installer does not mention RC or CTP. The page I posted for the KB you mention KB2506143 has the title "Windows Management Framework 3.0 - RC" microsoft.com/en-us/download/details.aspx?id=29939. Do you still have the problem after installing the RTM?
    – Clayton
    Oct 29 '12 at 21:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.