The GPO Startup scripts works fine on other machine but not for another half of the machine. gpresult show that GPO was there. I ran RSOP and it show that the Startup script was there but it was never executed. There nothing on application error or anything related to the failed execution in the event viewer.

I have set to Allow slow network connection too but it did not help for the startup script to execute.

Permission read/execute granted to Domain Computers & Authenticated Users

Other GPO settings works except Startup Script did not execute. The scripts works fine as other machine which success without any issue except some machine.

I need help to sort this out as it troubles me where another half of the machine did not execute the script at all. It was all WIndows 7.

closed as not a real question by Ward, rnxrx, EightBitTony, voretaq7 Oct 19 '12 at 19:15

It's difficult to tell what is being asked here. This question is ambiguous, vague, incomplete, overly broad, or rhetorical and cannot be reasonably answered in its current form. For help clarifying this question so that it can be reopened, visit the help center. If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    You're not giving us much info. basically you're saying "everything is the same but only works 50% of time". We have no idea how to tell you what's wrong based on that little info. Why not use group policy preferences rather then a script? It's very rare to need to use a script any more with all the options in GPO + GPP. Tell us what the script does. Better yet, link to a gist.github.com of the script (if it's long) or include it in your answer. – Bret Fisher Oct 8 '12 at 3:23

Build some simple debugging into your script - at the very least, make the first line log to a file that categorically proves whether the script ran or not. Include a date and time etc.

To me, it's highly plausible that the issue is somewhere within your script rather than whether Windows is running the script or not.

Not the answer you're looking for? Browse other questions tagged or ask your own question.