I've set up my home router(linksys) so it uses opendns.com as a content filter. I followed their simple guidelines. It works, but not as expected.

Please Note

I have three computers at home running Ubuntu. One laptop; two desktops; one desktop serves as a server (I may have more, if a friend asks me to fix their Windows machine).

Also, I use the routers MAC filter so only the machines I allow can access the internet.


  • Do I have to install the dynamic IP updating scripts (DDClient for Linux or the openDNS updater for Windows) into every machine I have or can I just install it in the server (which is always on), so it updates the dynamic IP in my openDNS account? Does every machine have a unique dinamic IP?
  • I brought a Windows machine to fix and it is able to access the internet even though I did not grant it permission on the router. This happened after I started using openDNS. Is this normal?

closed as off topic by Bryan, Wesley, Magellan, John Gardeniers, Ward Nov 25 '12 at 23:18

Questions on Server Fault are expected to relate to server, networking, or related infrastructure administration within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here. If this question can be reworded to fit the rules in the help center, please edit the question.

  • What do you mean "it works but not as expected"? Is it over/under filtering? – Keith Jul 21 '09 at 15:32
  • 1
    Sounds superuser.com to me ... – Kyle Brandt Jul 21 '09 at 15:37
  • this sounds more like a question about dynamic DNS, instead of open DNS. – Eric H Jul 21 '09 at 15:47
  • First: I thought that setting openDNS up in the router was just enough setup. It seems I also have to set a dynamic IP updater per machine. ; Second: It prevents my router from filtering by MAC address – lamcro Jul 21 '09 at 16:13

It is sufficient that the router do dynamic DNS. The machines will not need to if they all reside behind the router and use it as a NAT. If all the machines have an internally assigned IP such as 192.168.1.x then they are all seen as coming from the same IP address. Ensure all your machines are behind the router.

Regarding the windows machine that is able to access the Internet. Either the router security is configured incorrectly or the Windows machine is somehow on the outside network. Any MAC address filtering has nothing to do with OpenDNS or DNS at all.


openDNS will only work the way you've specified if you have your client machines also use it.

The benefit of putting the openDNS DNS servers into your router is that information will then get served to your DHCP clients.

I'd guess that you set up the linux machines with static IPs, so they're never getting the information from the router.


I have a similar set up. You need to run the dynamic dns client of your router and use the OpenDNS service (not dyndns or similar) to update the dynamic IP address. Then, once you set up your filtering criteria on OpenDNS, things will work fine.

The only catch may be with your ISP. Sometimes, a router can have 3 upstream DNS servers specified. OpenDNS only uses 2 and the third one may sometimes default to that of your ISP. In that case, the filtering may not always work.

The issue with the foreign Windows machines sound like they are latching onto another network.

  • "use the OpenDNS service to update the dynamic IP address": you mean the DDClient for Linux? – lamcro Jul 23 '09 at 12:53
  • You can use any client you wish, but the client should connect to the servers specified by OpenDNS (dns-o-matic). – sybreon Jul 24 '09 at 8:57

Not the answer you're looking for? Browse other questions tagged or ask your own question.