This strange problem has started recently. Some windows clients cannot seem to get dns resolution to the internet after boot, and sometimes again at some point in the day. Internal hosts are also slow to resolve. trying to ping an interal host by name will take a long time for the hostname to resolve to ip address and trying to ping a website by name will fail to resolve. If you go into the tcp/ip v4 properties and view but not change anything, ok/close out of that then the client starts working fine, hostnames will resolve quickly. I have seen this happen on both Vista and W7 clients.

ipconfig /all at a client experiencing this problem shows everything in order. proper ip addr, gateway, dns server, dns suffix ect..

ipconfig /dnsflush will not fix them, neither will /release and /renew

the clients get their ip address, mask and dns server info from either one of 2 OES dhcp servers that assign addresses in different scopes in the same subnet.

the internal dns server is a different OES dns server

the default gateway is not assigned by the OES server but is statically put in at the client (only for those who need to get to the Internet for their job)

flat network topology

What can I do to get to the bottom of this? It only happens to a few of the client machines and typically the same ones.

It started happening when we made a change to one of the DHCP scopes in iManager. Strangly this problem only happens to clients that get an IP address from the scope that we didn't make any changes to.

  • 1
    Can you post the configurations for the working and non-working DHCP scopes?
    – James Yale
    Oct 8 '12 at 17:01
  • When a machine is experiencing the issue, what do nslookups of a fqdn (I'd try both an internal and external name as well as both with and without a trailing ".") to your internal resolver look?i.e. nslookup www.fqdn.etc internal.resolvers.ip, nslookup www.fqdn.etc. internal.resolvers.ip, nslookup www.fqdn.etc, and nslookup www.fqdn.etc. Jan 11 '13 at 4:13

Please check DNS suffix on clients or check did you have DNS forwarders. This may be a problem.


Since a change was made to the working scope, I would suggest refreshing the unchanged scope and/or resetting all of the IP address leases, forcing the clients to refresh all information on network connect. The TCP/IP IPV4 page may have "Validate settings upon exit" checked, which refreshes the settings.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.