I'm trying to restore a cube backup (a .abf file) using SQL Server Management Studio, but I'm getting the error message:

The following system error occurred: The file exists. . (Microsoft SQL Server 2005 Analysis Services)

(yes, there really are two dots)

Does anyone know how to resolve this so I can restore the backup?

Here are the steps I'm using:

  • Open Microsoft SQL Server Management Studio
  • Make the connection to the AS server
  • Right-click on the Databases node on the server tree view
  • Choose Restore...
  • Type in a new database name in Restore database
  • Select the backup file in From backup file
  • Enter the correct password
  • Optionally tick Allow database overwrite (it happens both ways)
  • Press OK --> get the above error message

3 Answers 3


Well, it seems that the reason for the problem is that the backup was of a SQL Server Analysis Services 2008 cube. I'd have preferred a nice simple "This backup is not compatible with this version." error message, but hopefully this question will help anyone else with this problem in the future!

In case you're wondering, this backup was from a customer that I thought was running AS2005, but was actually running AS2008.


Hmm, usually this error occurs when you are performing a backup, not restoring a backup.

Are you 100000% sure you're doing a restore, and not another backup?

The only thing I can think of is to restart the SSAS service and see if that makes any difference?

Can you perhaps post the steps you are performing, or the script you are running?

  • Unfortunately you've overflowed my percentage meter there, but I'm sure I'm doing a restore :) I'll post the steps in the question, thanks!
    – Ant
    Jul 22, 2009 at 8:29

Most likly your TEMP folder contains to many files.

Try checking your temp folder - C:\Documents and Settings\WindowsLoginName\Local Settings\Temp

If you have a ton of files in there, delete them. Make sure you have enough space for the temp files the process will create.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.