I'm running VMware Server 2 and have created Virtual Machine Shortcuts for our various VMs. How do I save the VM login/password so I don't need to enter it each time I launch the shortcut?


You can add "-u username" and "-p password" to the command-line shortcut to pass a username and password to the program.

Be sure not to use to -M option to reference the VM ID as this breaks the username/password feature. Use the datastore path to the VMX instead

  • Hmm, didn't work. I still get the "Authenticate" window with an empty Username and Pasword field. – arathorn Jul 21 '09 at 19:31
  • Okay, looks like you have to add the -u and -p options immediately after the -h option. – arathorn Jul 21 '09 at 19:36
  • BUT, it's now reporting "Login failed due to a bad username or password". I'm sure they are correct, though -- I use the same values in the login window. – arathorn Jul 21 '09 at 19:38
  • I've tried putting the values in quotes, and also prefixing my username with DOMAIN\ (it is my domain login). No luck still. – arathorn Jul 21 '09 at 19:40
  • 1
    Okay, got it, thanks to this thread: communities.vmware.com/thread/… In addition to putting the -u and -p options immediately after the -h option, I had to remove the [-M <id>] option from the shortcut, and put the datastore path to the vmx file, like this: "[datastore] VMDir/VMFile.vmx" – arathorn Jul 21 '09 at 20:06

Right click on the Shortcut and select properties. change the properties so that it looks like below:

"D:\Program Files\Common Files\VMware\VMware Remote Console Plug-in\vmware-vmrc.exe" -h vmhost:8333 -u -p "[Vmware-01] VS2005-XP/VS2005-XP.vmx"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.