Installing Fedora 17 on a new computer with the live CD ISO.

When I get to the part where I create new partitions for the Fedora Installation I get these errors:

you have not created a bootloader stage1 target device

sda must have a gpt disk label

closed as off topic by Michael Hampton, Ward, rnxrx, Brent Pabst, John Gardeniers Oct 16 '12 at 13:15

Questions on Server Fault are expected to relate to server, networking, or related infrastructure administration within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here. If this question can be reworded to fit the rules in the help center, please edit the question.

  • Please post your solution as an answer to the question and accept it, this will let other people with the same problem know that the problem has been answered – DerfK Oct 13 '12 at 15:19
  • I cannot. It tells me I have to wait 8 hours because I don't have enough rep. I will do it later. – Charity Leschinski Oct 13 '12 at 19:36
  • Sorry, this should be moved to superuser – Charity Leschinski Feb 27 '13 at 19:46

This website helped identify the problem:


I was booting the Fedora LiveCD from "EFI" mode rather than BIOS mode. To find out which mode you are currently booting under, use the following steps:

First, when you have booted to the fedora liveCD, press Ctrl+Alt+F2 which will bring up a new prompt. Login as root (no password). Then use this command:

dmesg | grep EFI

If this command produces no output, or perhaps one or two lines in which "EFI" is embedded in other words, then you're booted in BIOS mode. If, however, you get dozens of lines of output, most of which refer to EFI memory settings, then Linux is booted in UEFI mode.

My problem was that I was booting the Fedora CD in UEFI mode because the DVD player I was using was from a previous older computer. So in order to alleviate the errors defined at the top, we will have to get fedora to boot in BIOS mode, not EFI mode.


Reboot the computer, pressed Delete to get into the BIOS, (you may have to use a different key). Go over to your boot options. You see "Boot Priority Order", the first boot priority device was set to EFI: DVD Rom. This was my problem, the DVD I poached from another computer was screwing up how Fedora was installing.

My BIOS Setup utility is by ACER Inc Version 2.14.

The solution is to change this Boot priority to use the other DVD Rom setting: (mine said: "CD&DVD: HL-DT-ST DV..." which does not include the term "EFI". I set this to be higher than the other one.

So it turns out that if you poach a DVD drive from another computer into a new computer, it can give you trouble when trying to install Fedora 17.


You have to create a /boot partition and populate it with files from the bootloader package. The bootloader is GRUB. This should be done automatically by the installer. You just have to let it do it's thing.

Read this section and section 9.14 after that.


  • Thanks for the input, but this doesn't apply in my situation. My DVD player is newer and I just installed it. It supports EFI, but my current partitions on my current hard drive does not. The Fedora installation CD incorrectly thinks I have an EFI partition system, but I do not. Therefore in order to use that method, I would have to delete my partition table on my current hard drive and lose Windows. – Charity Leschinski Oct 13 '12 at 15:20
  • 1
    It's usually possible to manually specify where you want the boot partition. You don't have to let the installer take over your drive. – Ярослав Рахматуллин Oct 13 '12 at 15:23
  • I tried to automatically let the installer create the partitions and it gave me the error. I even manually tried to set up partitions with the correct drive as the boot drive and it gave me the same error. This may be a bug in the installer, but I found a work around. – Charity Leschinski Oct 13 '12 at 15:26

Not the answer you're looking for? Browse other questions tagged or ask your own question.