1

I'm trying to install the Amazon Web Services PHP SDK on my Ubuntu LAMP server. Whenever I run the compatibly check everything but cURL comes back okay. The issue I'm having is that it's reporting I don't have cURL with SSL. I uninstalled curl then installed curl-ssl with no avail.

  • Belongs to Serverfault. – BudwiseЯ Oct 15 '12 at 0:59
2

Maybe you forgot some packages to install libcurl4-openssl-dev?

sudo apt-get remove --purge php5-curl && \
sudo apt-get install libcurl4-openssl-dev curl-ssl php5-curl

Then restart server:

sudo apachectl -k restart

This question should be on maybe serverfault.com/ubuntu

| improve this answer | |
  • Worked, your awesome. From now on I'll try to make sure post my questions in the appropriate forum. – user1580785 Oct 15 '12 at 1:07
  • Ok. This already fixed. – Marin Sagovac Oct 15 '12 at 1:08
0

I am facing the same issue with my EC-2 faced the issue with the above answer. Then I found a command

sudo apt-get install curl libcurl3 libcurl3-dev php5-curl

This help me fix the issue.

for more reference

https://askubuntu.com/questions/530323/how-to-make-curl-and-php-available-when-installed-from-xampp?newreg=720483ecd77b4d0aaa09da29c79de8a3

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.