During our migration process from SBS2003 to Windows Server 2008 R2, I copied the user home directories across to their new location on the Windows 2008 R2 server.

I have a specific problem with one of the users.

She can access her files and folders "\old_server\users\HerUserName" and she can access her files in her My Documents on "\new_server\users\HerUserName\My Documents".

However when I copy her other folders in her user home directory across to the new server, i.e. "\old_server\users\HerUserName\Directory1" to "\new_server\users\HerUserName\Directory1" (using XCopy or RoboCopy), the folder and its content is copied across to the new server, and I can see the folder on the new server, but when browsing to the share from her desktop, she can only see her "My Documents" folder.

I have verified that she is the Owner of the folder that was copied to her home directory, and all the permissions also look ok.

Any assistance would be appreciated.

1 Answer 1


Try using this on the server: attrib -s -h c:\users\HerUserName

Do this for each folder she can't see.

I guess robocopy set the hidden and/or system attribute on the copied folders. Already noticed this behaviour myself when copying from one server to another where they didn't know each others user accounts.

  • Thanks for contributing. I was reviewing your answer as it is in the "late answers" queue, and all I would add is an actual explanation of what the command options do. (and in this specific case a reminder that having users with the same name does not mean it is the same user, since windows internally uses a security identifier which is created uniquely every time you create an account. To avoid problems like that a Domain is used. And restoring files as the actual target user is a good help to give them full ownership).
    – eckes
    Dec 13, 2012 at 2:29
  • Thanks for the answer. I will except it, taking note of the comment by eckes as well.
    – Riaan
    Dec 14, 2012 at 16:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.