Even after taking ownership of a newly created directory called "NewWebsite" inside the existing "c:\inetpub\" on a Windows Server 2008 R2 (SP1) I do not have full access. The most obvious symptom is right-click "New" only has "Folder" with the UAC icon.


I am setting up our product (a website) on a Windows Server 2008 R2 Standard (SP1), which is a virtual machine hosted by one of our clients (I don't know which virtual technology, but I don't think it matters - if it does let me know).

The machine has been created for me by the client (who is snowed under and doesn't have time to help me) and the account I access the machine with is part of the local Administrators group.

I have created a new folder in the "c:\inetpub\" for the project with the name "NewWebsite" (just an example), and I have taken ownership of the folder using this answer. I also made sure I ticked the Replace owner on subcontainers and objects checkbox before OKing through the windows.

The problem is that I still do not appear to have ownership of the folder, the most basic example being that the "New" sub-menu when right-clicking in the folder only has "Folder" with the UAC icon next to it... it does not have the normal list of file types.

I've tried logging off, and back in again... I have tried creating a sub folder and reapplying the ownership, it doesn't matter what I do I simply don't have full control over the folder.

Could this be an issue with group-policy, or am I missing something obvious?

(I've had to do this on a previous client machine, and I'm sure it was easy to do - unfortunately I didn't take notes at the time, so I can't remember exactly what I did)


From what I can tell, the "inetpub" directory is protected by the virtue of being a system folder, and therefore standard ownership was not going to work.

My client has given my account Full Control of the c:\inetpub\ folder, and I now have the access I require. (I guess this is something I could have done myself, as I had local Administrator access on the machine).


It sounds like you've taken ownership fine but you haven't added a permission to allow yourself to have access. Taking ownership does not grant permission-- those are two different things. (The "CREATOR OWNER" security principal sorta mixes the two together, I suppose...)

Modify the ACL on the folder and add "Your User / Full Control" permission. I suspect things will go fine for you after that.

  • Thanks @Evan - I believe my account had full control thanks to its inclusion in the local Administrators group. However, the client has just (in the last few minutes) given my account specific Full Control of the inetpub folder structure, which has given me all the permission I need! – freefaller Oct 17 '12 at 12:02
  • With UAC enabled your token doesn't contain an Administrators group membership. UAC strips your token of privileged groups. Think about it like that and you'll see why you didn't have access. – Evan Anderson Oct 17 '12 at 13:09

I think it has something to do with IIS and that IIS_USR is actually owner on that folder . Being by default the owner on windows , you might not be able to change that there .

You might want to try to use another folder inside of it and assign full rights for your self (why do you need ownership on that folder ? ).

If you're trying to create a website , you might want to use IIS manager as it might be easier than any workaround to use .

  • Thanks @Alex - I want ownership so I have easy control over the files in there. Despite rigorous testing, live sites always need tweaking for a couple of weeks, and so having permission into the directory is exceedingly useful (I admit not actually "needed", but makes my life easier)! And I think you're right, I was coming to the same conclusion on the inetpub folder – freefaller Oct 17 '12 at 12:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.