When I configure IIS to run a Web site on Port 1414, I get the following error:

--------------------------- Internet Information Services (IIS) Manager
--------------------------- The process cannot access the file because it is being used by another process. (Exception from HRESULT: 0x80070020)

However, as according to netstat the port is not in use.

Completely aside from IIS, I wrote a test program (just to open the port and test it):

TcpListener tcpListener;
tcpListener = new TcpListener(IPAddress.Any, port);
     Console.WriteLine("Press \"q\" key to quit.");
     ConsoleKeyInfo key;
          key = Console.ReadKey();
     } while (key.KeyChar != 'q');
 catch (Exception ex)

The result was an exception and the following ex.Message:

An attempt was made to access a socket in a way forbidden by its access permissions

The port was available but its "access permissions" are not allowing me access. This remains after several restarts.

The port is not reserved or in use as far as I know and while IIS says it is in use, netstat and my test program say it is not and my test program receives the error that I am not allowed to access the port. The test program ran elevated. The IIS Site is running MQSeries, but the MQ listener also cannot start on port 1414 because of this issue. A quick search of my registry found nothing interesting for port 1414.

What are socket access permissions and how can I correct mine to allow access?

Update: Output of netstat for port 1414.

C:\Windows\system32>netstat -ban|findstr 1414


  • Have you tried turning your firewall off to see if it's the same issue as in this question here? Oct 24, 2012 at 15:21
  • I can't turn the FW off. However, IIS does work on other ports (which are also not in use). I tested IIS on port 70 (which is blocked) and the Web site started (although would not be accessible from outside the server). Oct 24, 2012 at 15:57

2 Answers 2


According to IBM documentation, mq defaults to 1414, so you won't be able to have both a website and mq using the same port. (Unless I'm misunderstanding your question.)

  • That's why I wasn't mentioning MQ at first. The problem is that the port 1414 appears to be in use while netstat claims it isn't. It doesn't matter whether I try IIS or MQ, the port just doesn't work. Nov 13, 2012 at 8:28
  • Can we see the output of netstat? Nov 13, 2012 at 22:27

Above error is coming because default port 8080 is not assigned to system. So default website under IIS manager is not able start. To Resolve the above error i followed the below steps, and it worked for me.

Step 1 - Go to run, type cmd, command prompt will appear.

Step 2 - We need to find which process is using the default port 8080. To find this type the below command in your command prompt. Netstat -ano

Step 3 - As per above screen the port 8080 is using by the process 3152. Now we need to find which application is assigned for process id 3152. Type tasklist /fi “PID eq 3152” in your command prompt and see the result.

Step 4 - Start your default website in IIS manager. It will work.

For more detail check here

  • In this question the port was not in use by another process, as the output of netstat showed. Sep 8, 2015 at 14:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .