I am trying to set up SSH to a SCO Unix server that runs custom software that uses the function keys on the keyboard, however the keys do not appear to be in the correct format for SCO to recognise. None of the keyboard options on PuTTY work, including the SCO option.

How do I change the keycodes that SCO/bash is looking for when it wants a function key? If it helps, the system is upgrading from Wyse50 terminals.



I'd suggest using an ANSI or SCO ANSI emulation type.

The keybindings will be the biggest trick, but in my experience, ansi, ansi25 and scoansi have been winners for me.

For the keybindings, go to:

Session > Terminal > Keyboard

enter image description here

Also see the following for terminal type/string suggestions:

How to change the terminal to SCO compliant in Ubuntu

Anyone suggest a good ssh terminal emulator for windows (connecting to RHEL box) and proper terminal type?

  • I have tried all of the "Function keys and keypad" settings, but none of them work. I was looking to change what the SCO server expects to see for them. – CyberJacob Oct 18 '12 at 8:27
  • You're going to have less luck modifying your SCO-side termdef and more luck fixing the client side. Did you also change the terminal-type string in Session > Data? So you're going from terminals to PuTTY on PC's? Just to check, I would download an evaluation of Ericom Powerterm to make sure that this can be done. – ewwhite Oct 18 '12 at 12:23

As a long time SCO consultant, I concur, download the Ericom PowerTerm Lite and use it. It is around $79 per license. It is all we recommend and we have it running on Win 8 with pass through printing. Key mapping works great.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.