0

Cannot use puppet on mac osx 10.8, i can find it in /usr/bin/lib but display that when i launch it :

/usr/bin/puppet:3:in `require': no such file to load -- puppet/util/command_line (LoadError)
from /usr/bin/puppet:3

Any idea ?

Edit : I want to use puppet in Vagrant VM to do provisioning is it the good way ?

  • Please ask additional questions in a separate post. – Adrian Heine Oct 18 '12 at 7:26
3

I'm having the same issue as noted above (identical error). I've just installed from the suggested download site, puppet 2.7.20 and factor 1.6.14. facter presents a slightly different error message:

bash-3.2# facter /opt/local/lib/ruby/vendor_ruby/1.8/rubygems/custom_require.rb:31:in gem_original_require': no such file to load -- facter/application (LoadError) from /opt/local/lib/ruby/vendor_ruby/1.8/rubygems/custom_require.rb:31:inrequire' from /usr/bin/facter:69

Any suggestions would be helpful.

Thanks,

Carter

| improve this answer | |
0

How did you install puppet? The native packages we provide at http://downloads.puppetlabs.com/mac/?C=N;O=A should work well with Mac OS X 10.8. If you installed from another location, please let us know how so we can better help diagnose the problem.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.