2

I have Zabbix monitoring disk space for several volumes on several servers. It works fine on all of them except for one of the volumes on one of the servers which always reports as 0. However, when I run

./zabbix_get -s localhost -p 10050 -k 'vfs.fs.size[/home, free]'

locally on the machine in question, it gives me the correct, non-zero size which matches the output of df.

How can I go about troubleshooting and correcting this problem?

4
  • What is in the agent log? 1.x or 2.x? Active or passive check? – chris Oct 18 '12 at 17:02
  • @chris: There's no mention of the vfs key in the log or any errors. Only startup messages (collectors, listeners, active checks). It's version 2.0.0. And the checks are active. Values are returned successfully for other volumes on this server. – Dennis Williamson Oct 18 '12 at 17:10
  • Can you post a screenshot of the item config for this host? Also, what is the latest data/history for the item showing are there previous dates with values other than 0? – bmurtagh Nov 5 '12 at 0:23
  • @bmurtagh: It's the same template as used by other similar servers which do not exhibit this problem. As I said in the original post, this volume on this server always shows 0 in the Zabbix data screen, but zabbix_get always reports a correct value. – Dennis Williamson Nov 5 '12 at 3:51
0

It turns out that I had set the data type for /home to float, but for other volumes I had set it to unsigned decimal. On the servers that were reporting 0, the free space was larger than other servers and the value overflowed the field.

Setting the field type to unsigned decimal to match the others corrected the problem.

0

(Just wanted to add my contribute if someone else pops by)

Thanks to this question I discovered zabbix_get, that I installed with yum install zabbix-get through Zabbix Repositories.

If you get no data from zabbix_get -s 127.0.0.1 -k agent.version (this is a simple key to check this utility), check the Server= option in /etc/zabbix/zabbix_agentd.conf and be sure it contains localhost:

Server=myserver.mycompany.com,127.0.0.1
0

In my case it was because unusual filesystem simfs. I added its name to regular expression @File systems for discovery in Administration->General->Drop down "Regular expressions" and now it works.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.