1

gcc is complaining with the following when trying to sudo easy_install readline:

Running readline-6.2.4/setup.py -q bdist_egg --dist-dir /tmp/easy_install-JEUNX3/readline-6.2.4/egg-dist-tmp-_THoHR
/usr/bin/ld: cannot find -lncurses
collect2: ld returned 1 exit status
error: Setup script exited with error: command 'gcc' failed with exit status 1

Am I missing some RPM dependency for a happy build environment?

Linux vbweb 3.2.22-35.60.amzn1.x86_64

Thanks!

1
  • Doesn't Amazon provide a readline package?! I swear, the more I hear about Amazon's AMIs, the less I like them. Oct 19, 2012 at 14:58

1 Answer 1

1

You need to install the ncurses development package: yum install libncurses-dev.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .