In our Production environment, CF Administrator works fine. But in Test, some pages don't come up... meaning a blank page in the frame is returned (while the left nav and top bars remain). No error is generated.

For instance, the Scheduled Tasks page shows up fine, but clicking on a task blanks the page and you can't do anything but click Scheduled Tasks in the left nav bar. Most other pages are giving me the same problem, such as the JVM page.

So I tried copying the /settings/jvm.cfm file from Production to Test and it worked! I did the same for \scheduler\scheduleedit.cfm (for the scheduled tasks detail view), and it worked there, too.

So can I just copy the whole \administrator folder down from Production?
I wonder why these files aren't working.

Production and Test are both running the same version of CF, with the same updater. I'm pretty sure the same hotfixes were installed, but where would I verify that to make sure? This file is the one present in both... /lib/updates/chf9010002.jar

  • 1
    If you get anything from over there let me know. I had a similar but not exact problem last year. I ended up just reinstalling coldfusion. stackoverflow.com/questions/8561345/… – Travis Oct 11 '12 at 1:45
  • I think this belongs back at stackoverflow, and not at serverFault. I think the core answer will be with ColdFusion folks. – sugardaddy Oct 25 '12 at 18:22

Did you already resolve this issue? From the behavior you are describing I wonder if it would help to clear the template cache on the affected server and force ColdFusion to recompile it's templates. Just a thought.

  • I have not resolved it. I was waiting to see if I received any more advice before I made a plan. My current thought is to reinstall ColdFusion 9. But looking into the template cache seems like a great thing to try. Thanks! – sugardaddy Nov 30 '12 at 13:30
  • As far as checking the hotfixes on each server there is no easy way that I know of. However, you can compare from the System Information page of the ColdFusion administrator on each. Compare the version number, update level, and the class paths from that page. Also under the Caching section of the admin, what settings do you have for Trusted cache and Save class files? You could also delete any saved class files in the {war-root}\WEB-INF\cfclasses directory. Restart ColdFusion after doing so and see if that helps. – Miguel-F Nov 30 '12 at 13:41
  • Thanks Miguel. I've changed jobs since then, so I can't test that any more. But that seems like a good attempt at a solution. Maybe if someone else has this issue down the line, they can add more wisdom to this. – sugardaddy Jul 17 '13 at 16:41

I had this problem again in Windows 7, and the solution was to start up a new browser using "Run as administrator". That let me set a directory mapping when it wouldn't work under my normal browser.

Apparently some operations within CF Admin have different perms than others.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.