2

No matter how hard i tried skype still can not connect to its server.

Able to access other HTTPS servers like gmail,but skype is not working through proxy.

squid proxy server

eth0:192.168.2.22 with internet connection

eth1:192.168.1.1 connected to LAN

Squid running on port 3128

able to access HTTP and HTTPS websites but skype can not.

specified Host and port in squids connection page,but still skype can not connect to proxy server.

It is not even showing any skype activity in accesslog.

1

Quit skype and remove shared.xml file and start skype again.

Dont specify either port or proxy ip. Skype will detect it automatically. This should probably solve it.

0

If you are running on Windows you can set the proxy manually in skype:

Tools->Options->Advanced->Connection

Proxy set to : HTTPS
Host: your.proxy.server.ip
Port: squid port
  • 1
    Thats how i configured it,but still i can not make this to work. Also i can not see any request from skype in the access list of squid. – Blue Gene Oct 22 '12 at 12:01
  • Have you set the proxy to HTTPS? – Francois Wolmarans Oct 22 '12 at 12:42
  • Yes,its HTTPS only.Should i need to make any changes in the squid.conf file? – Blue Gene Oct 22 '12 at 12:50
  • Install iptraf on the squid box, and filter on your ip. This will show whether the traffic is reaching the ethernet port on your server. – Francois Wolmarans Oct 22 '12 at 13:29
  • installed iptraf,No issue with reachability,but when i removed shared.xml it worked.But can not make it to work again even after removing shared.xml – Blue Gene Oct 22 '12 at 13:45
0

Skype will only use the Proxy Server configuration if it cannot find another route to the Internet.

To force Skype to use your Proxy, you have to edit the Registry settings for the Skype client.

Its covered in the Administrators Guide:

http://download.skype.com/share/business/guides/skype-it-administrators-guide.pdf

If you want to confirm this, setup a firewall rule to block outbound access from everything except your proxy server.

That's how I figured it out.

0

I made the following changes to my configuration, after which the problem was solved. This is in Windows 7.

1) On Skype login screen, tools menu -> connection options, put '36479' in 'use port for incoming connections'. Under this, set 'automatic proxy detection'

2) Set proxy at system level. To do this, open Internet Explorer, go to Tools -> Internet options -> Connections -> LAN settings -> Advanced. Set proxy server details in HTTP and Secure fields. Tick 'Use a proxy server for your LAN' on LAN settings screen.

3) I'm using Squidguard as well as Squid. As a precaution, I added the domain skype.com to Squidguard's white list.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.