1

One of my current company servers is using old Fedora 8 and web apps compatible with PHP 5.2.x.

Currently the PHP version is 5.2.4. I would like to upgrade it minimum 5.2.5 so that Drupal-7 can be installed on that machine.

The problem is, there are no more repository for Fedora 8, and maybe here someone could help.

I can't risk upgrading the OS since I'm not linux expert, and if anything goes wrong I could be in trouble.

thanks

6
  • 2
    Your risk is much greater by running Fedora 8 than by using something which is modern and supported. Get rid of it as soon as possible. – Michael Hampton Oct 22 '12 at 14:06
  • if we upgrade the OS, the PHP will have version 5.3 (latest) or perhaps 5.4 which my company applications don't support. – Bonn Oct 22 '12 at 16:51
  • Drupal 7 is perfectly well supported in PHP 5.3. No idea about 5.4. And it's much less risky to fix the custom applications to work with PHP 5.3 than to run an outdated OS which is never going to get security fixes. Not to mention the outdated version of PHP which is never going to get security fixes. – Michael Hampton Oct 22 '12 at 16:53
  • 3
    Fedora 8 was End-of-Lifed on 2009-07-10. That's over 3 years since the last patch. This has no business being on the network anymore. This sounds like a more systematic problem than just an out of date version of PHP. – Scott Pack Oct 22 '12 at 16:58
  • 3+ years without updates and not hacked yet? Man, you are lucky. – c2h5oh Oct 24 '12 at 3:42
5

You have a few options:

  1. Do Nothing.
    Your system will continue to run in its current state until someone waltzes in through a gaping 3-year-old security hole and deletes all your data.
    The blame will probably land on you for failing to upgrade the system and keep current with security patches.

  2. Upgrade PHP Manually
    Download the source code from http://www.php.net , build the version you need, and install it.
    While you're at it you should probably upgrade Apache (plenty of major security issues fixed in the last 3 years!), which means you'll probably want to build PHP & Apache together in a sandbox somewhere.

  3. Replace the system
    Install a modern, supported operating system on a new server, copy your software on to it, perform regression tests (fixing any problems you find in your software), and then swap systems.


Frankly (3) is the only responsible option, though (2) is often exercised for internal reasons.
If you chose (1) or (2) you should write copious memos detailing the major problems inherent with staying on an ancient, unsupported OS with known security vulnerabilities to mitigate the amount of fallout that lands on you when something goes wrong.

If you are not comfortable with option (2) or (3) because you are "not [a] linux expert" my suggestion is that you find a consultant to help you out. You are in a bad place right now, and you need to get out of that bad place as quickly as possible before things get substantially worse..

0
  1. Archived site

    If you really want to keep running Fedora 8, there's an official archive site, take a look at the README file, you'll find it. Then you can change your baseurl setting of yum repository to the the archive site URL. Hopefully, you can upgraded php version to php-5.2.6-2.fc8

  2. Virtual machine

    1. You can try install a new OS (Fedora 17, CentOS 6, etc...) in a virtual machine, which will not affect your current OS, to test if your company application is compatible with new verion of php.
    2. Or, just install Drupal 7 in the virtual machine, and use mod_proxy to forward the request from fedora 8 to the virtual machine

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.